Periodic FPS drop on Linux

I’m getting periodic FPS drops on Linux Mint 20.3. I’m using NVIDIA driver version 510.47.03. Tested on Windows 10, same machine, no FPS drop on Windows.

I also tried previous driver version (470). This happens with any stream game I tried and brings the game to a complete halt for 6 seconds and then jump back to 60 FPS.

Not going back to Windows on this machine, would rather go team red. I don’t see these issues there with Linux to be honest.

Any ideas would be appreciated. Will supply more info if needed.

Please run as root and attach the resulting nvidia-bug-report.log.gz file to your post.

nvidia-bug-report.log.gz (309.4 KB)

Thank you for the quick response. I have attached the nvidia-bug-report.log.gz file.

Please set kernel parameter
If that doesn’t help, please do a longer gaming session and create a new nvidia-bug-report.log afterwards.


Setting the kernel parameter “nvidia-drm.modeset=1” did not solve or change the issue. I have attached a log after a longer gaming session.
Some additional things I tried:

Changing graphics settings to lowest in game also had no effect.
Tried using “Gamemoderun” a package that is suppose to optimize gaming performance on linux.
I monitored system resources and didn’t see any other process spike during the periodic FPS drop.
nvidia-bug-report.log.gz (313.7 KB)


Please check if you can limit clocks by running
nvidia-smi -lgc 300,1500
to rule out throttling due to overheating on boost.


Glad to report that setting “nvidia-smi -lgc 300,1500” made the issue less frequent. The GPU was running at 66c so I’m not sure why any throttling would occur. The issue still happens once roughly every 10 minutes.

Should I try a lower setting and how do I persist that setting? (The command gives a warning that it doesn’t persist)

Really appreciate the help.

Since it’s obviously connected to overheating, I found this:
So instead of tinkering more with nvidia-smi, please rather upgrade your kernel first:
sudo apt install --install-recommends linux-generic-hwe-20.04
so you get access to the other profiles but only the “silent” one.

For autostart applications in general, please see this:


That installed linux kernel 5.13.0-30-generic. I’m not sure if the patch rolled into that version but the issue remains.

Please post the output of
cat /sys/devices/platform/asus-nb-wmi/throttle_thermal_policy

The throttle_thermal_policy outputs a “0”

“0” should be normal mode. Please check if you can install “asus_fanmode” which is a daemon that controls that setting.