permanent setting log_num_mtt and log_mtts_per_seg

I am using MHEH29 with MLNX_OFED 1.5.3. on centos 6.2.

To increase memory size, I set log_num_mtt and log_mtts_per_seg as

#echo “22” > /sys/module/mlx4_core/parameters/log_num_mtt

#echo “1” > /sys/module/mlx4_core/parameters/log_mtts_per_seg

Once these values are set, IPoIB works fine, but these values return to 0 upon rebooting.

According to the discussion in this forum, HowTo Increase Memory Size used by Mellanox Adapters https://community.mellanox.com/s/article/howto-increase-memory-size-used-by-mellanox-adapters

I looked for the file /etc/modprobe.d/mlx4_core.conf, but cannot find that file.

Is there any way to set those values permanently?

Where should I look for the mlx4_core.conf file other than the above directory?

Thanks! It worked.

Hello,

If the file /etc/modprobe.d/mlx4_core.conf does not exist, create file then input the desired parameter followed by restart of the driver(# /etc/init.d/openibd restart)

Cheers,

~R