pgcc error

I want to install both szip and hdf on our cluster using the PGI 19.10 compiler. However, both installations have the error related to pgcc compiler. Here is the error while configuring szip.
Export PGI_CURR_CUDA_HOME=/home/zxy471/application/pgi/19.10/pgilinux-2019-1910-ppc64le/linuxpower/2019/cuda/

Export PGI=/home/zxy471/application/pgi/19.10/pgilinux-2019-1910-ppc64le

pgcc-Warning-No files to process



configure:3371: $? = 0

configure:3360: pgcc -V >&5



pgcc 19.10-0 linuxpower target on Linuxpower

PGI Compilers and Tools

Copyright © 2019, NVIDIA CORPORATION. All rights reserved.

configure:3371: $? = 0

configure:3360: pgcc -qversion >&5

pgcc-Error-Unknown switch: -qversion

configure:3371: $? = 1

configure:3391: checking whether the C compiler works

configure:3413: pgcc -fsigned-char -DNO_WARN_X86_INTRINSICS conftest.c >&5

pgcc-Error-Unknown switch: -fsigned-char


I tested PGI compiler which works fine. If you could give me any hints, that would be greatly appreciated. Thank you!

Best,
Zhifeng

Hi Zhifeng,

The error here are because pgcc doesn’t use the flags “-qversion” or “-fsigned-char”. Our equivalent flags are “-V” and “-Mschar”.

Is configure aborting due to this and not something else? Typically it will attempt several flags until if find the correct one for the compiler.

Are there any additional details from the resulting log file that might give clues?

-Mat

Hi Mat,
It seems it used “-V” before using “-qversion”. I am not sure why it used both of them. I have not taken a look at configure file.

I think all the error information is in the config.log file. I am not sure whether there are some other issues before this error. To me, there is no error before this. Here is the whole config.log file. I copied it here, since I could find how to attach a file when I reply.

This file contains any messages produced by compilers while
running configure, to aid debugging if configure makes a mistake.

It was created by SZIP configure 2.1.1, which was
generated by GNU Autoconf 2.69. Invocation command line was

$ ./configure --prefix=/home/zxy471/application/pgi/19.10/szip-2.1.1

It seems that I could not copy the whole config.log file, since there was an error “403 Forbidden”. So I only copy the first few lines. Do you know how I can send you the file?
Thank you

It seems it used “-V” before using “-qversion”. I am not sure why it used both of them.

That’s just how configure works. It tests a bunch of options to see what is and isn’t supported.

Do you know how I can send you the file?

I don’t really need the whole file, just the bit where the failing error occur. Should be towards the bottom of config.log above where’s it’s dumped the cache variables.

Note that I did download SZIP from https://support.hdfgroup.org/doc_resource/SZIP/ and didn’t have any issues configuring or building it on Power. I just set “CC=pgcc”, “FC=pgfortran”, then ran “./configure --prefix=…”. So the problem seems to be something local to your system.

-Mat

Here is the information just before “cache variables”
pgcc 19.10-0 linuxpower target on Linuxpower
PGI Compilers and Tools
Copyright © 2019, NVIDIA CORPORATION. All rights reserved.
configure:3371: $? = 0
configure:3360: pgcc -qversion >&5
pgcc-Error-Unknown switch: -qversion
configure:3371: $? = 1
configure:3391: checking whether the C compiler works
configure:3413: pgcc -fsigned-char -DNO_WARN_X86_INTRINSICS conftest.c >&5
pgcc-Error-Unknown switch: -fsigned-char
configure:3417: $? = 1
configure:3455: result: no
configure: failed program was:


configure:3460: error: in /home/zxy471/application/pgi/19.10/source_code/szip-2.1.1': configure:3462: error: C compiler cannot create executables See config.log’ for more details

I did compile szip successfully on another power machine before. This time, it’s another power machine. What kind of local system problems could lead to the configuration failure?

Sorry, no idea. Since this is a problem with SZIP’s configure setup, you may need to contact the authors.

If I could recreate the error here, I might be able to determine the issue, but like you on your other system, it just works for me.

-Mat

I just solved it with the help from the hdf group. The error was caused by the C flag ‘-fsigned-char’. I set the CFLAGS. export CFLAGS=’ '.

Aah, so my first answer was the correct one. I just thought it was configure adding “-fsigned-char” for some reason not that it was part of the flags you were passing.

-Mat