pgcollect failed

I followed the user guide and tried the jacobi iteration example.
However, when I tried pgcollect ./a.out,

it indiate :
pgcollect-Error-Required tool pgsampt was not found
pgcollect… looked for pgsampt at /opt/pgi/linux86-64/15.7/bin/pgsampt
pgcollect-Error-Required tool pgevtofq was not found
pgcollect… looked for pgevtofq at /opt/pgi/linux86-64/15.7/bin/pgevtofq

How to fix this ?

I am running on Ubuntu 14.04.2 LTS


This is an odd one and not one I’ve seen before. I’m guessing it’s an install or permissions issue.

Do the files “/opt/pgi/linux86-64/15.7/bin/pgsampt” and “/opt/pgi/linux86-64/15.7/bin/pgevtofq” exist? If so, do you have execute permissions?

  • Mat

No, both of them did not exist.

Odd. They are part of the install package so should be there. Either they got deleted after install or there was an error during your installation.

Can you try re-installing and see if that fixes the problem?

  • Mat

Hi Mat,

I don’t have those files either.

Neither in target dir nor in distrib one - OpenACCtoolkit/linux86-64/15.7/bin


same issue with *.jar

Ok, this explains it. The NVIDIA OpenACC Toolkit (OTK) shouldn’t include the PGI profiler. Users are instead encouraged to use the included NVIDIA nvprof profiler.

It looks like pgcollect and pgprof were accident left in the package. I’ll pass this on to the folks who put together the OTK package and see if we can remove them in the next release.