PGF90-S-0084-Illegal use of symbol - not public entity ..

when compiling the ECHAM5(Linux-x64+PGI7.0), a following error occurs.

PGF90-S-0084-Illegal use of symbol local_decomposition - not public entity of module (mo_chem_bcond_io.f90: 54)
0 inform, 0 warnings, 1 severes, 0 fatal for xt_read_emiss_fields_so2

Any suggestion will be appreciated.

Hi terry1012,

I’d like to have you try compiling with the latest PGI compilers (9.0). While I don’t see an error report specific to ECHAM5, I do see a similar issue where we weren’t exporting predefined symbols such as generic correctly in the 7.0 release. (TPR#4090)

For example:

> > cat test.f90
module m
intrinsic max
end module m

program test
use m, ren => max
end program test

> > pgf90 test.f90
PGF90-S-0084-Illegal use of symbol max - not public entity of module (test.f90: 6)
0 inform, 0 warnings, 1 severes, 0 fatal for test

While it could be unrelated, I know of other users who have compiled ECHAM5 successfully with later version of the compilers. Unfortunately, I don’t have access to ECHAM5 myself, otherwise, I would verify this for you.

Hope this helps,

Hi, Mat

I have tried PGI9.0 and the error remains.

Does it probably caused by incorrect load of MPI library or sth. else?


Hi Terry,

Another engineer here had echam-5.5.00_rc1 and I was able to compile it without issue with 9.0. So either there is a problem with the source code you have or there is something wrong in your environment.

Which version of ECHAM do you have? Could your modules be old?

  • Mat

Hi, Mat,

My code is not just ECHAM but ECHAM-HAM and the error occured in the HAM module. I could also compile successfully the ECHAM model only.

Could you give me your Email address so that I can send the original code to you and you can have a further check about the PGI?

Thank you!


Hi Terry,

Please send a reproducing example to PGI Customer Service ( and ask them to forward it to me. I’ll what I can determine.


Hi there,
How was this problem solved?
I am facing it too.


Hi there,
How was this problem solved?
I am facing it too with PGI v9


Hi Genito,

I don’t have a record of Terry sending me this code so I’m not sure if or what was done to fix it. I also looked through our issue tracking system but found no reference to ECHAM-HAM.

Can you send me (via trs) a reproducing case?


This problem occurs when compiling ECHAM + HAM1 and
is solved by adding the following lines

             USE mo_decomposition,     ONLY: gc => global_decomposition,   &
                                  dc => local_decomposition

at the beginning of module mo_chem_bcond_io, at line 14, after

USE mo_aero_mem,    ONLY: input

This was fixed in later versions of HAM, e.g. ECHAM 5.5+HAM2.

Regards, Jost