PGF90-W-0006-Input File Empty

Hello,

It seems that the PGI pgf90 compiler for Windows delete my fortran codes!

When I start the PGI workstation and try to run make to compile some FORTRAN codes it gives me error:

PGF90-W-0006-Input File Empty (whatever_file.f)

After that I check the files in the directory and the FORTRAN files are empty (zero size)! The compiler delete them! and some of them are with extention .i instead .f as before compiling.

Please tell me what wrong I do.

Thanks a lot!

Sincerely,

Angel Dimitrov
Varna, Bulgaria
http://www.stormlab.net

wow! I found the error:

############################
rm -f gbytesys.f
rm -f gribcode.o
pgcc -C -P -DDEC -DBIT32 gribcode.F > gribcode.f
C:\PROGRA~1\PGI/license.dat: product ‘pgf77-win32’ is not permanently licensed
or this host
pgf90 -c -Mfreeform -byteswapio gribcode.f
C:\PROGRA~1\PGI/license.dat: product ‘pgf90-win32’ is not permanently licensed
or this host
PGF90-W-0006-Input file empty (gribcode.f)
PGF90/x86 nt86 6.0-5: compilation completed with warnings
#########################

the makefile delete the fortran file with rm -f!

Angel Dimitrov
stormlab.net

I removed the “rm -f” from the makefile and all other flags to test but it still delete the .F files… any ideas?

Angel
stormlab.net

I found the problem - it was in the Makefile…
Angel

Hi Angel,

You probably figured this out but “pgcc -P” sends the output to an intermediate file (".i") not to standard output. For this case, you should either use “cpp” or pgf90 directly on the “.F”. pgf90 has a preprocessor built in which is envoked when a file ends with “.F” or “.F90” or when the flag “-Mpreprocess” is used.

Hope this helps,
Mat

Thanks a lot for your replay!

This will save time while compiling.

Angel Dimitrov
stormlab.net

Thanks!

Angel

Thanks Mat!

Your help is greatly appreciated!

Angel