pgnvd-Error-CUDADIR value is not a directory

Dear PGI users/support


I’ve installed PGI 14.10 and CUDA 6.5 on my mac OS X 10.10 computer.

If I run ‘pgaccelinfo’ I get normal output that tells me properties of my video card (which is GeForce GT 330M in case this info is relevant here).

I am trying to build some of the examples in
/opt/pgi/osx86-64/2014/examples/OpenACC/samples/acc_c1
by running ‘make build’.

I get the following error:

pgnvd-Error-CUDADIR value is not a directory: /opt/pgi/osx86-64/2014/cuda/5.5/bin
PGC-F-0155-Compiler failed to translate accelerator region (see -Minfo messages): Device compiler exited with error status code (acc_c1.c: 1)
PGC/x86-64 OSX 14.10-0: compilation aborted
make: *** [build] Error 2

Indeed there is no ‘/opt/pgi/osx86-64/2014/cuda/5.5’ directory. (There are 6.0 and 6.5 directories though).

Can you suggest what is wrong here?

Thanks,
Eugene.

Hi Eugene,

This is being caused by an issue with the PGI installer. Mac OSX 10.10 wont be officially supported until next year’s 15.1 release and the 14.10 installer is incorrectly setting the default CUDA version to CUDA 5.5 on your system.

You can override the default CUDA version from the command line via the flag “-ta=tesla:cuda6.0”.

Also, you can remove the line “DEFCUDAVERSION=5.5;” from the file “/opt/pgi/osx86-64/bin/localrc”.

Hope this helps,
Mat

Dear Mat,
I’ ve installed CUDA8.0 on Ubuntu16.04 before installed PGI16.10 complier.

When I try to compile a test file by using command ’ pgc++ -acc main.cpp -o main’, some errors occur. The error code are:

pgnvd-Error-CUDADIR value is not a directory: /opt/pgi/linux86-64/2016/cuda/7.0/bin

PGCC-F-0155-Compiler failed to translate accelerator region (see -Minfo messages): Device compiler exited with error status code (main.cpp: 1)
PGCC/x86 Linux 16.10-0: compilation aborted

There’s indeed no directory ‘/opt/pgi/linux86-64/2016/cuda/7.0/bin’.

Then I tried to use command flag -ta=tesla:cuda8.0, but result a new problem. The error message is:
‘pgc+±Error-CUDA version 8.0 is not available in this installation’

Hope you can help me this problem. Thanks.

Remove the PGI installation, and install again.

Say yes/accept to everything, including installing the PGI software
and libs that allow it to run/control the GPUs. The GPUs were separately
updated with the CUDA 8.0 driver, but the PGI compilers need their CUDA
versions of libs, headers, and tools to make programs that use the GPUs.

I’ve done it as you said. It works.

Thank you very much!