Pip libraries in USD Composer not installing

I’m having trouble with pip libraries and the new USD Composer that replaced Create. In my extension, I’m using some third-party libraries from pip, which I’ve been importing through the extension.toml configuration e.g.

requirements = ['pandas']
use_online_index = true

This has been working fine in Code, View, and Create, but fails in the USD Composer app that recently replaced Create with an error like ModuleNotFoundError: No module named 'pandas' .

I’m having the same issue with “pandas” and “opencv-python”; once again only on the new USD Composer app as it used to work just fine on 2022.3.* versions.

Same issue in Code. I tried opencv, opencv-python.
I tried the “script editor” in omniverse Code as well

I found an issue that on the first installation our pipapi extension tries to update pip to an older version, which we probably didn’t update since the python update.

There is a custom hack you can do, in that file:

change line _attempted_to_upgrade_pip = False to _attempted_to_upgrade_pip = True

then you need to clean app data (pip installation dir specifically), either manually remove:
or restart an app with --clear-data CLI flag

After that I was able to install pandas.

Thanks @anovoselov !
Is this the omni.kit.pipapi\omni\kit\pipapi\pipapi.py file that is in the USDComposer extscache? (i.e. C:\Users\SFOEBB\AppData\Local\ov\pkg\create-2023.1.0\extscache\omni.kit.pipapi-0.0.0+ed961c5c\omni\kit\pipapi\pipapi.py)