Pip3 warning

When I use pip3:

What can i do?

nano@nano-desktop:~/Desktop$ pip3 install --upgrade pip3
WARNING: The directory ‘/home/nano/.cache/pip/http’ or its parent directory is not owned by the current user and the cache has been disabled. Please check the permissions and owner of that directory. If executing pip with sudo, you may want sudo’s -H flag.
WARNING: The directory ‘/home/nano/.cache/pip’ or its parent directory is not owned by the current user and caching wheels has been disabled. check the permissions and owner of that directory. If executing pip with sudo, you may want sudo’s -H flag.
Collecting pip3
ERROR: Could not find a version that satisfies the requirement pip3 (from versions: none)
ERROR: No matching distribution found for pip3
WARNING: You are using pip version 19.2.2, however version 19.2.3 is available.
You should consider upgrading via the ‘pip install --upgrade pip’ command.

Hi,

This is a harmless warning.
The log indicates that you don’t have permission for ‘/home/nano/.cache/pip/http’.

If you want to upgrade pip3, please use this command instead:

pip3 install --upgrade <b>pip</b>

Thanks.

I guess this has been introduced by the latest Jetpack 4.2.2.

The TERMINAL window of the SDK Manager when installing JetPack 4.2.2 showed the followings:

17:46:53 INFO : TensorFlow : sudo pip3 install -U pip
17:46:53 INFO : TensorFlow : sudo pip3 install -U numpy grpcio absl-py py-cpuinfo psutil portpicker six mock requests gast h5py astor termcolor protobuf keras-applications keras-preprocessing wrapt google-pasta
17:46:53 INFO : TensorFlow : sudo pip3 install --pre --extra-index-url https://developer.download.nvidia.com/compute/redist/jp/v42 tensorflow-gpu==1.14.0+nv19.7

The problem is pip3 was executed as sudo without specifying/disabling a cache directory, which makes a cache directory of pip at the default location, in the user home directory, as root. That forces us to use sudo for further pip operations or to specify a different cache directory.

It is not a big deal, but could be confusing.

Thanks buddy, I tried to chmod 777 -R /home/nano ,it seems that it helps.

Thanks, I have updated it.

jetbot@jetbot:~$ sudo pip3 install Jetson.GPIO
WARNING: The directory ‘/home/jetbot/.cache/pip’ or its parent directory is not owned or is not writable by the current user. The cache has been disabled. Check the permissions and owner of that directory. If executing pip with sudo, you should use sudo’s -H flag.
Requirement already satisfied: Jetson.GPIO in /usr/lib/python3/dist-packages (2.0.16)
WARNING: Running pip as the ‘root’ user can result in broken permissions and conflicting behaviour with the system package manager. It is recommended to use a virtual environment instead: https://pip.pypa.io/warnings/venv

any one pls I need help. 10Q