pipeline problem with Arducam

Hello,

First i have installed ‘cv2’ package, next i have cloned python code to run ‘Arducam’ or ‘CSI’ camera from here

https://github.com/JetsonHacksNano/CSI-Camera

Next i have tured off Jeston, connect camera, turn jetson on and run this command as it says in ‘readme.md’

“gst-launch-1.0 nvarguscamerasrc ! ‘video/x-raw(memory:NVMM),width=3820, height=2464, framerate=21/1, format=NV12’ ! nvvidconv flip-method=0 ! ‘video/x-raw,width=960, height=616’ ! nvvidconv ! nvegltransform ! nveglglessink -e”

the output this

"
Setting pipeline to PAUSED …

Using winsys: x11
Pipeline is live and does not need PREROLL …
Got context from element ‘eglglessink0’: gst.egl.EGLDisplay=context, display=(GstEGLDisplay)NULL;
Setting pipeline to PLAYING …
New clock: GstSystemClock
Error generated. /dvs/git/dirty/git-master_linux/multimedia/nvgstreamer/gst-nvarguscamera/gstnvarguscamerasrc.cpp, execute:532 No cameras available
Got EOS from element “pipeline0”.
Execution ended after 0:00:00.503356390
Setting pipeline to PAUSED …
Setting pipeline to READY …
Setting pipeline to NULL …
Freeing pipeline …

"

Also there are some python files like “simple_camera.py” or "face_detect.py "
When I run

" python simple_camera.py "

the output is

"
nvarguscamerasrc ! video/x-raw(memory:NVMM), width=(int)2592, height=(int)1944, format=(string)NV12, framerate=(fraction)30/1 ! nvvidconv flip-method=0 ! video/x-raw, width=(int)1280, height=(int)720, format=(string)BGRx ! videoconvert ! video/x-raw, format=(string)BGR ! appsink
Unable to open camera
"

Also I have checked cameras with raspberry pi and they work well.

I think problem is with piplines, please help.

Check is any video node in the /dev
ls /dev/video*

Check the sensors format.
v4l2-ctl --list-formats-ext

I have checked there is no video node in

/dev

it says

ls: cannot access ‘/dev/video*’: No such file or directory

the same for

/dev/video*

When I run

v4l2-ctl --list-formats

or

v4l2-ctl --list-formats-ext

the output is

Failed to open /dev/video0: No such file or director

The device not even probe on the system.
You need to contact to Arducam to get the correct driver to get the camera working.