Planetside 2 GPU Particles and Motion Blur

Hi, I’m running a Nvidia Geforce GTX 970M and Intel i7-6700HQ CPU @ 2.60GHz 2.59 GHz on a Windows 10 64 bit system. I’ve looked this up and I keep being told that I need a Nvidia graphics card to turn GPU particles on in Planetside 2, but whenever I turn it up to high and restart the game, they’re turned back off. Motion blur is greyed out as well. I don’t know if Daybreak turned these off because they’re incompatible with Windows 10 or if you guys are working on a patch for it, or if it’s just not compatible with the notebook graphics cards. Either way, I’d really like a fix for this or at least know why I’m not able to turn these options on. Thank you!