Please help: hung during boot, fastboot menu not reachable - Tegra Note 7 (Advent VEGA)

Hi,

Personal&intro:
I’m a dev changing the horses, sniffing around on the Android platform. Originally wanted to start with “user” apps development (*), then hack slightly deeper into the architecture and internals. After a short sniff on my brothers TrekSTOR HD7 I searched for the best HW I could find and despite some logistic problems of getting my hands on it, I got the Tegra Note 7 (and its really great! I would say WOOOOW, more then WOW64, probably WOW128 ;-)

Problem:
Before I could even start as a user-app dev, after a few days of BFU-only settling-in and playing around my device hung miraculously - after power on it goes through the first logo and than starts the animated one where it hungs for about 15-20 minutes, before I switch it off. If Im correct, this means, that either the init or the Zygote & Dalvik VM inicialization hangs somewhere.

Diagnostics so far:

  • I was never able to get it into the fastboot menu (power+volUp), when I needed to root it (droid 4.2.2) I had to restart it into fastboot through an ADB command.
    (ok, I rooted the device about 2 weeks ago and I’am afraid that I messed up something using a full TitaniumBackup restore yesterday)

  • Thus, I have no way to do a “factory” restore - when started normally (and the USB debugging was ON as far as I can remember) it does not get so far to be seen on ADB and I have no way how to boot to fastboot protocol to do the recovery from the fastboot.exe and the “hardware” way of PWR+VolUP does not work.

  • However Im able to get to the APX mode (driver installed, Win7pro64b), but thats the end of the story, since that is the final frontier for my knowledge so far

  • Special observation: when it hangs during the boot and I make a forced power-off (Power for about 6 secs, then immediate release when it shuts down), it suddenly (within 2-3 secs) powers on again!!! Only way how to get it off permanently is to hold the power+VolUp+Down untill screen blank, continue hold the VolUp+Dwn for about 30 secs and then it is still - no APX mode, but the APX can then be reached as usuall)

What I need to know:

  • any other way I can force it to get to recovery (fastboot) menu, as I have seen on varius videos and on my brothers tablet?
  • if not, how to restore it back to the original state flashing it in the APX mode?
    OK, I admit, I have no idea, WHICH part (bootloader? main image?) is wrong and what should I flash and how, since I have no clue of how the internal memmory is organised and what and how can be rewritten (and where to get the files from - I have only backed up the big ZIPs with OTA updates from nvidia sites). Since I dug a little deeper, I understood, that if the part when the device hangs is it’s system “only” (init/Zygote/Dalvik), then only flashing only the system partition of the memory should be sufficient, but have no idea how to do it in the APX mode.

Can anybody help? When further info needed, I will provide as far as Im able. This quite embrassing for me, since I wanted to get to these internals anyway, but it came much too early :-/

Thanks

(*) eg. not going further then inside the Dalvik VM, using AIDE - it is mostly TXT only, git integration, small and fast to understand and to understand the logic, the compiler sources etc., without all the havoc Eclipse/IDEA/Visual studio android projs. have

Hi, a short update to this:

  • the most painfull problem has been solved, suddenly the ADB@USB sprung back miraculously (before I did not get it even after logn waiting, now it is back only a few seconds after boot, however it is still stuck on the logo only).

  • I tried “adb reboot bootloader” … hm, it worked up to one tiny trouble: the bootloader options GUI screen NEVER appeared!!! The only way I was able to communicate with the device was the “fastboot utility”.

  • then rebooted back to “normal” (eg. the hung state stucking on the animated logo) and rebooted using “adb reboot recovery” … what a surprise! there was the android logo stating “No command” (in czech, se attached image) … WTF??? I never tampered with the system (as written above, haven’t had the guts to fiddle with nvflash flashing the storage yet) so where is my alternate recovery system?

  • ok, so I did one more “adb reboot bootloader” (again, nothing on the screen, but fastboot saw the device - God thanks for that!) and then “fastboot -w” … this did the trick, system came back, after that it was a piece of cake restoring from a previous backup

But still:

  • WHY does my nVidia Tegra NOTE 7 (Advent VEGA) not allow to get into the graphical bootloader - not even with the Pwr+VolUP, not with Pwr+VolDWN, not with the “adb reboot bootloader”??? Thanks havens for the fastboot default “ON”, because when Im in the bootloader, the screen is lit, but black
  • Where is / why is not anything on the “restore” partition present?
  • What to do, when the device bricks again? Cross my fingers and hope the ADB service will somehow make it through the INIT again? I would really appreciate a clue how to get it up and running using the APX.

Thanks in advance

Sorry not to be able to help but this “Linux for Tegra” is for the “traditional” Linux and there’s a separate section for Android. Maybe you could try asking in there? Also the http://www.xda-developers.com/ is a very good forum to Android hacking discussions.

Thanks for redirect, but if somebody should find this looking for the same clue as I did, now the solution can be found: the advent company has published a full package including a nvflash working with the Tegra Note 7. Moreover, it contains a signed bootloader and bct and all the other parts of the entire storage (including the system partition for 4.3). It can be downloaded from here: http://www.adventcomputers.co.uk/product-downloads select Product range: “Advent”; Product type: “Tablet”; and then choose “ADVENT Vega Tegra Note 7”, do not be mystified by the “driver” type and download the “Advent Vega Tegra Note Factory Image (4.3)” (about 641 MB package)

Many thanks to the dev and support guys at Advent (Dixons retail plc), because they have put the final cherry on the top of the cake. The Nvidia Tegra Note 7 is now not only a top of the top devices regarding its power, but this package renders it into an unbrickable device.

Thanks for the update!

Hi rheingold, i have a similar problem, even worse i cant even access fastboot, I can access APX though. Mine is an EVGA version of the tablet.

I understand that the signed bct and blobs may be different, but please outline the steps for using the nvflash.

Thank you.

hi xcelcio, you need to turn off ur tg7 first… if volume up + volume down doesnt work, u gotta try holding the power button long enuf. i fixed my bricked tg7 yesterday… hope u can fix urs too

For anyone arriving here, as I did, with essentially an unresponsive/bricked Tegra Note 7 after an OTA (over the air) update to Lollipop, I thought I’d share my experience to add to the above advice.

My wife’s Advent Tegra Note 7 received an over the air upgrade to Android Lollipop (5) which appeared to install but then got stuck in a cycle of “Optimising Updates”. It would do this then reboot then do it all again with no progress.

So I downloaded the OTA update manually from XDA (here: http://forum.xda-developers.com/showthread.php?t=2570807 ) and saved then zip file (do not unzip it) to a Micro SD Card.

I then put that card into the Tegra Note and switched it off by holding the power button for what seemed like ages.

Once it was off I held Volume Up and Power together for about 5 seconds. This gives you the Fastboot menu. Use Volume Down to move to “Recovery Kernel” and then press Power.

After a few seconds you are met with a picture of an Android with its chest open and a warning sign over it. Hold Volume Up and Power again until a new menu appears (this is the Recovery menu). Release Volume Up first then Power. Now use Volume Down to move to “Wipe Data/Cache Factory” or similar and press Power. WARNING: THIS WILL WIPE ALL YOUR USER DATA FROM THE DEVICE AND YOU WON’T BE ABLE TO GET IT BACK but it was the only way I could get the decvice working and the upgrade applied.

Once it has finished you should be back at the Recovery menu. Use Volume Down to move to “Install update from External SD card” and press Power.

You will be shown a list of any update zip files on the SD card - in my case there was just the one and so it was already selected. If required move to the one you want to apply (using Volume Down again) and then press Power.

After about five minutes (with updates on the screen) your Tegra will reboot and you should find yourself in a Welcome wizard for Lollipop.

Enjoy.