Poor DMA performance over PCIe from FPGA

Keep your “dma-coherent” property there in the device tree even though trying to disable SMMU.