Port forwarding in Jetson AGX Orin Developer Kit

I’m trying to define ssh port forwarding to SoM device that is connected to the Jetson via ethernet cable (eth0 interface).
The Jetson is connected to a wifi network via interface wlan0 and our goal is to define the port forwarding to the SoM device using port 2222.
This port is enabled for ssh traffic.
We tried to run the following commands:
sudo iptables -A PREROUTING -t nat -i wlan0 -p tcp --dport 2220 -j DNAT --to
sudo iptables -A FORWARD -p tcp -d --dport 22 -j ACCEPT


sudo iptables -t nat -A PREROUTING -p tcp -i wlan0 --dport 2222 -j DNAT --to-destination
sudo iptables -t nat -A POSTROUTING -j MASQUERADE

It seem like the firewall is blocking the communication somehow and we tried to allow traffic on port 2222 but it did not work.

Did someone here ever define port forwarding successfully in Jetson Orin?

We can’t answer this networking issue, may other developers help to share experiences.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.