Portability for newer linux versions?

I have an old compiling machine with redhat 9 and pgi 4. Tried downloading the portability package (there is only one for 4.1 not 4.0), but when I try to run the install script, it says that it does not recognize my glibc version (2.7).

Is there a way to get this to work so that I can run programs compiled on my compiling machine on newer linux boxes?

Hi,

We started having portability package in 4.1.

You probably can update makelocalrc file (~line 164) to accept glibc 2.7(make it similar to GLIBC2.3). We don’t know if it will work with latest OS.


I would recommend you try out latest release.

Hongyon