Posenet crash/boot only with resnet18-hand on AGX Orin

Have been having a great old time for weeks with AGX Orin DK running and testing all the tremendous updated Hello AI imagenet, segnet, and posenet etc examples on my data plus the samples.

No issues from a many times apt updated original jetson-inference clone installation on the AGX Orin.

Posenet has been working fine with the resnet18-body and densenet121-body networks for any image I give it.

When I try to run posenet with resnet18-hand, .cpp or .py, I see several seconds of the initial process steps for setting up the net, then the system reboots (power light goes off then on).

No traces left after restart…

Tried different images, no dice. Re-downloaded resnet18-hand through ./download-models but that didn’t help.

Didn’t see anything on the Jetson Forum, but I found this:

Better Call … no, I can’t write it….


Haha, hi @trelease! I just tested resnet18-body model again through posenet/posenet.py on Jetson AGX Orin, and it ran without issues. That is odd that yours results in a system reboot as opposed to a segfault/ect - typically that may indicate a power supply issue. Can you try changing the power mode (with nvpmodel) to a lower-power mode to see if it’s power related?

Also, can you try deleting the .engine file in the jetson-inference/data/networks/Pose-ResNet18-Hand folder so that TensorRT will re-generate it the next time you run posenet?

Also, what is the command you are running?

Wow! Thanks!

BTW been running MAXN. Tried both .py and .cpp launches before

Sitting down to retry with 50W.

There’s no .engine file in jetson-inference/data/networks/Pose-Resnet18-Hand. Just onnx, json, and colors.txt. No engine built before it blew, eh?



I bow to the Master!

The resnet18-hand engine built fine at 50W with the cpp posenet, tho’ it seemed a bit slow compared to all the other (resnet#) builds at MAXN. ;)

So, can you help me understand why I might be generating a panic or summat by trying to run at MAXN? Have I got a problematic USB C supply or cable?

Thank you yet again!

Live long and prosper.

“Oh. That’s different. Nevermind…”

Non-NV USB C PS claimed it was 100 W.

Okay gotcha - yea, sudden blackouts/brownouts of the device under computational load typically point to a power supply issue. Glad you were able to get it figured!

Thanks for pointing the way!
Mo’ headroom

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.