Possible 346.35 regression: Hardware cursor not drawn on top screen edge

After an update to 346.35, I have noticed that my cursor disappeared when close to the top screen edge, which I don’t remember it doing before. I tried to record the behaviour with x11grab, but noticed that x11grab did correctly draw the cursor. Thus this lead me to assume that it is a regression in the hardware-accelerated cursor drawing.

Video 1: x11grab recorded seemingly correctly working cursor (H.264 in mkv, 3.8 MB)
Video 2: Phone camera recording of what I actually see (H.264 in mkv, 6.5 MB)

My desktop environment is KDE, my distro is ArchLinux.

Can anyone else reproduce the issue?

don’t want to hijack the thread but i have a similar issue that’s maybe related. i’m on kubuntu with kde and my pointer changes shape when passing over different things, es. it gets smaller when over folders in menus and in gtk windows. it’s just a minor glitch but i have it since kubuntu 14.10 regardless of the drivers, so i thought it was kde related.

yes, me!

i use openSUSE 13.2 x86_64 with KDE 4.14.3

Sounds like a KDE issue to me, possibly related to weird DPI settings since you’ve mentioned it gets smaller in GTK windows. Install one of the GTK KCMs and check your settings.
If you want to confirm that it’s not a driver issue, I’d recommend you try the same thing I do: record the bug with ffmpeg through x11grab. If it also appears in the capture, it’s probably not a hardware cursor bug. To do such a capture, try:

ffmpeg -video_size 1920x1080 -framerate 30 -f x11grab -i :0.0 -c:v libx264 -qp 0 -preset veryfast cap.mkv

Press q in the terminal window to finish recording. Obviously, adjust -video_size as needed.
Sadly, Ubuntu still ships the Libav fork, so some command line options may differ a bit; if that’s the case I recommend just grabbing the static ffmpeg build off the ffmpeg website.

Afterwards, play back the cap.mkv. If the cursor looks normal, the problem might be related. If the cursor is buggy in x11grab too, it’s most likely not related to this thread at all.

yeah still undecided, it’s really a cosmetic glitch and with kubuntu 15 at the horizon (plasma 5 and wayland) probably not worth the effort for me. thanx a lot for the tips and i hope your issue is resolved. btw have you tried trivial things like changing cursor theme or disabling compositing?

Yes, neither work though.

so i guess you tried also using nouveau… only thing that comes to my mind is a similar problem with the top edge of the screen, and it was related to the klauncher…

I have the same issue here, but only on my second monitor. In addition, cursor movement in the second monitor is somewhat choppy in that it would skip frames every second or so.

Relevant information: http://i.imgur.com/O7wh4Vm.png

I’m using the i3 window manager, so it is definitely not an issue with klauncher. I was also using the compton compositor, but killing that had no effect on the issue.

Here’s the relevant information in my xorg.conf:

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "DELL U2711"
    HorizSync       29.0 - 113.0
    VertRefresh     49.0 - 86.0
    Option         "DPMS"

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce GTX 970"

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "Stereo" "0"
    Option         "nvidiaXineramaInfoOrder" "DFP-0"
    Option         "metamodes" "DVI-I-1: nvidia-auto-select +1080+0, DVI-D-0: nvidia-auto-select +0+0 {rotation=left}"
    Option         "SLI" "Off"
    Option         "MultiGPU" "Off"
    Option         "BaseMosaic" "off"
    SubSection     "Display"
        Depth       24

It is interesting that dilu only sees this on his second monitor. I’m on a optimus device, so perhaps that’s what’s triggering it for me on my primary monitor. As for choppiness of the cursor, I can’t really comment on this with my cursor as I’m using a touchpad, so I’m expecting the cursor to be choppy at times due to either the touchpad being inaccurate or my sausage fingers.

I notice that this bug appears when using { ForceFullCompositionPipeline = On } to force Vsync, removing this option in the xorg.conf fix that, just remove logout and login.

I had not noticed it until I saw this thread title, but yes, I have the exact same issue on Ubuntu 14.10 with the 346.35 drivers.

I don’t actually use that, but I use TripleBuffer. Will try disabling that and report back with results the next time I log out.

TripleBuffer disabled, switched to version 346.47. Issue still present.

Can confirm, also having this issue on ubuntu 14.10, version 346.47, using GTX 850M. It only happens when using the “NVIDIA” profile, not the “Intel” one, as set in nvidia-settings.

Mouse just disappears when it reaches the top of the screen, exactly as video #2 in the top post demonstrates. A bit annoying as that’s where my browser tabs are.

“Intel” profile seems to work flawlessly, even when rendering full-screen steam games with primusrun - mouse does not disappear.

I am NOT using KDE, but i3wm on its own. It even happens in lightdm (login manager), even before logging in to any session.

Please provide nvidia bug report by running nvidia-bug-report.sh script as root user? What was the earlier driver don’t have this issue?

The earlier drivers did not show this issue, but that is only because I had not been able to set the “NVIDIA” profile in nvidia-settings. Every time I switched the setting and restarted, it would revert to “Intel” on its own. I just shrugged it off and used primusrun for games, and it worked well enough.

Yesterday, I did some tests with 331.113, 340.76. I were not able to switch to “NVIDIA” profile in either of them, but it was possible with 346.47.

An extra piece of information: When I set the profile to “NVIDIA” in 346.47, a black screen appears for 20-25 seconds before lightdm shows up. With “Intel” it always shows up instantaneously, in all driver versions tested.

Here is the log from nvidia-bug-report.sh, when using the “NVIDIA” profile.

I have noticed this also, when I had Chromium fullscreen and wanted to switch tabs and mouse disappears when close to the top. Odd thing is that it only happens on one monitor (0,0) off 3.

Cannot really say when it was introduced though but maybe the last 2 drivers?

nvidia-bug-report.log.gz (84.3 KB)

Here’s a bug report file

Sorry for forgetting about that.

I don’t exactly remember what the previously working version was, though it most likely was nvidia-343.36 according to my package cache.

Thanks for looking into this.

I saw the same issue on all six screens (3x NVS 315 cards, each with two flat panels attached) when I upgraded from 340.76 to 346.47. I’m running the screens in portrait mode (rotated `left’ with xrandr); the cursor vanishes as soon as the edge of the cursor touches the top edge of the screen.
I use plain old ctwm, without any fancy compositing or anything of the sort.

it seems fixed with new beta driver 349.12.
at least for me.