Possible Bad eMMC?

Had jet pack 3.3 on it just fine, but decided to upgrade to latest since it now supported TX1 again. Flashing gets stuck at 99.8 or 99.9% almost every time.

The one time it actually finished, it booted a couple of times fine, then started boot loops ( too fast to read any errors on the screen )

Back to installing 4.2.1, and back to getting to 99.8, then several hours later, to 99.9 but never gets past that.

Is my hardware hosed?

I couldn’t tell you how to fix it, but people with good hardware have run into this before. Much of the time this is from the host being a VM, and if you are using a VM, then this is probably why it is happening. However, sometimes people run into this for other reasons than a VM. Someone else may know the answer if this is not a VM host.

Note: A serial console log would allow you to post the boot log since it still shows up even if the Jetson crashes.

I have tried both vm and native ( both kvm and virtual box ). Its random on results. Its like it does whatever its in the mood to do at the time.

Just tried it again after i posted this, just out of desperation. And it loaded just fine.

After that it ran fine, thru several reboots for testing… even moved root to an SSD and rebooted a few times there. Let it run a while, did a few things with it. Then about 10 mins ago rebooted again, and its dead in the water again. Not even the logo this time :(

i have not yet hooked up a serial port, that will be next on my list now that its ‘dead’. Before it was rebooting so fast even if i could get to the console, it wouldn’t stay long enough to read.

Frustrating, as it used to work great. I had shut things down a while ago since i had some video issues with the older jetpack that the new one fixed ( mainly with chromium ).

I still have a couple of nanos for projects, but would be nice if its big brother worked.

To know for sure you will need the serial console. Serial console can log what is going on during the boot as well, and so it won’t matter if the Jetson dies or not…the log would be on your host and wouldn’t even require mouse copy and paste.

The logo not showing up is a different issue and would tend to point to hardware failure, but there are still some questions related to flash causing this. Were any of the flash commands to anything other than to the eMMC? Changing rootfs after flashing would not prevent earlier boot stages at all, while saying flash is to another device could tell the internal configuration something different which could cause even earlier boot stages to change.

For serial console, make sure the UART you get is 3.3V (TTL logic level). Settings would be speed 115200, 8-bits, no parity, one stop bit, no flow control (115200 8N1).

Also, is your monitor purely HDMI without any special adapters?

Would you believe it was the case? I had not yet posted the solution as i wanted to be sure. I noticed that one time as i closed the case after flashing it blinked, then reset ( again ). So out of a chance, i pulled it back out of the case and it ran fine… been rebooting, powering down, putting it under load, even re flashing a few time for days just to put it thru some cycles. Now its solid, like it used to be… Even flashing is going faster.

Had been in this case since i first bought it. It does not make any sense. All that is there is the power button and light + the 4 mounting posts.

Even pushed on the board some with it out, seeing if i had some cracked traces and the board was flexing in the case, but nothing.

its weird. but its working so i guess i don’t care. :)

Even on a PC I sometimes recommend starting off odd failure debugging with reseating any add-on cards. I am not surprised that pulling out of the case and putting back, or simply re-flashing would work.

I bought a new case, that just came today. Its got more room in it anyway. Been humming along for about 4 hours now. No incident.

I do have an SSD on it, but i did remove that too when it first started acting stupid.