Power button long press detected

Hello,
I test my designed board with nano, but the nano can’t work ,the debug seriel print :
[0003.376] uhub0: <Nvidia XHCI root HUB, class 9/0, rev 3.00/1.00, addr 1> on usbus0
[0004.026] uhub0: 9 ports with 9 removable, self powered
[0005.026] failed to get HID devices
[0005.029] failed to init xhci or no usb device attached
[0008.037] Power button long press detected
[0008.041] Entering fastboot mode…
[0008.044] starting fastboot mode
[0008.048] fastboot cmd_init done.
[0008.052] platform does not support off-mode-charge
[0008.056] usbdcd_init Initialize USBF driver
[0008.061] usbdcd_phy_open oscfreq = 5
[0008.070] usbdcd_start Start the initialized controller
[0008.076] get_fastb-- suspend –
o[0008.079] ot_instructions: Error -2 finding instructions in /chosen
[0008.101] Key Code 8 not handled
[0008.304] Key Code 8 not handled

It shows “Power button long press detected”, then “Entering fastboot mode…”,
and finally ,it prints"Key Code 8 not handled" continuously,
is there any hardware failure on my board ?

thanks

Could you share the full log here?

[0000.126] [TegraBoot] (version 00.00.2018.01-l4t-89b97a49)
[0000.132] Processing in cold boot mode Bootloader 2
[0000.136] A02 Bootrom Patch rev = 1023
[0000.140] Power-up reason: pmc por
[0000.143] No Battery Present
[0000.146] pmic max77620 reset reason
[0000.149] pmic max77620 NVERC : 0x40
[0000.152] RamCode = 0
[0000.155] Platform has DDR4 type RAM
[0000.158] max77620 disabling SD1 Remote Sense
[0000.162] Setting DDR voltage to 1125mv
[0000.166] Serial Number of Pmic Max77663: 0x72de4
[0000.174] Entering ramdump check
[0000.177] Get RamDumpCarveOut = 0x0
[0000.180] RamDumpCarveOut=0x0, RamDumperFlag=0xe59ff3f8
[0000.185] Last reboot was clean, booting normally!
[0000.190] Sdram initialization is successful
[0000.194] SecureOs Carveout Base=0x00000000ff800000 Size=0x00800000
[0000.200] Lp0 Carveout Base=0x00000000ff780000 Size=0x00001000
[0000.206] BpmpFw Carveout Base=0x00000000ff700000 Size=0x00080000
[0000.212] GSC1 Carveout Base=0x00000000ff600000 Size=0x00100000
[0000.217] GSC2 Carveout Base=0x00000000ff500000 Size=0x00100000
[0000.223] GSC4 Carveout Base=0x00000000ff400000 Size=0x00100000
[0000.229] GSC5 Carveout Base=0x00000000ff300000 Size=0x00100000
[0000.235] GSC3 Carveout Base=0x000000017f300000 Size=0x00d00000
[0000.251] RamDump Carveout Base=0x00000000ff280000 Size=0x00080000
[0000.257] Platform-DebugCarveout: 0
[0000.260] Nck Carveout Base=0x00000000ff080000 Size=0x00200000
[0000.266] Non secure mode, and RB not enabled.
[0000.485] Csd NumOfBlocks=62333952
[0000.490] Set High speed to 1
[0000.494] Error mask set in wait for cmd complete with error 0x3 in HwSdmmcWaitForCommandComplete func at 278 line
[0000.504] Command complete wait failed with error 0x3 Interrupt 0x18001
[0000.510] Number of retries left 4
[0000.522] Using GPT Primary to query partitions
[0000.526] Loading Tboot-CPU binary
[0000.539] Verifying TBC in OdmNonSecureSBK mode
[0000.549] Bootloader load address is 0xa0000000, entry address is 0xa0000258
[0000.556] Bootloader downloaded successfully.
[0000.560] Downloaded Tboot-CPU binary to 0xa0000258
[0000.565] MAX77620_GPIO5 configured
[0000.568] CPU power rail is up
[0000.571] CPU clock enabled
[0000.575] Performing RAM repair
[0000.578] Updating A64 Warmreset Address to 0xa00002e9
[0000.583] Loading NvTbootBootloaderDTB
[0000.620] Verifying NvTbootBootloaderDTB in OdmNonSecureSBK mode
[0000.685] Bootloader DTB Load Address: 0x83000000
[0000.690] Loading NvTbootKernelDTB
[0000.727] Verifying NvTbootKernelDTB in OdmNonSecureSBK mode
[0000.791] Kernel DTB Load Address: 0x83100000
[0000.798] Loading cboot binary
[0000.841] Verifying EBT in OdmNonSecureSBK mode
[0000.884] Bootloader load address is 0x92c00000, entry address is 0x92c00258
[0000.891] Bootloader downloaded successfully.
[0000.895] Next binary entry address: 0x92c00258
[0000.900] BoardId: 3448
[0000.904] Overriding pmu board id with proc board id
[0000.909] Display board id is not available
[0000.951] Verifying SC7EntryFw in OdmNonSecureSBK mode
[0001.003] /bpmp deleted
[0001.005] SC7EntryFw header found loaded at 0xff700000
[0001.194] OVR2 PMIC
[0001.196] Bpmp FW successfully loaded
[0001.201] WB0 init successfully at 0xff780000
[0001.205] Set NvDecSticky Bits
[0001.209] GSC2 address ff53fffc value c0edbbcc
[0001.215] GSC MC Settings done
[0001.220] TOS Image length 53680
[0001.223] Monitor size 53680
[0001.226] OS size 0
[0001.236] Secure Os AES-CMAC Verification Success!
[0001.240] TOS image cipher info: plaintext
[0001.244] Loading and Validation of Secure OS Successful
[0001.260] SC7 Entry Firmware - 0xff700000, 0x4000
[0001.265] NvTbootPackSdramParams: start.
[0001.270] NvTbootPackSdramParams: done.
[0001.274] Tegraboot started after 53949 us
[0001.278] Basic modules init took 881726 us
[0001.282] NvTbootQspiFlashIoctl: Opcode = 1 not supported
[0001.287] Sec Bootdevice Read Time = 622327755 ms, Read Size = 622327755 KB
[0001.294] Sec Bootdevice Write Time = 0 ms, Write Size = 0 KB
[0001.299] Storage Device Read Time = 179 ms, Read Size = 2226 KB
[0001.305] Storage Device Write Time = 0 ms, Write Size = 0 KB
[0001.310] Next stage binary read took 38981 us
[0001.315] Carveout took -50643 us
[0001.318] CPU initialization took 380572 us
[0001.322] Total time taken by TegraBoot 1250636 us

[0001.327] Starting CPU & Halting co-processor

64NOTICE: BL31: v1.3(release):a28d87f09
NOTICE: BL31: Built : 16:52:46, Jul 16 2019
ERROR: Error initializing runtime service trusty_fast
[0001.449] RamCode = 0
[0001.453] LPDDR4 Training: Read DT: Number of tables = 2
[0001.458] EMC Training (SRC-freq: 204000; DST-freq: 1600000)
[0001.471] EMC Training Successful
[0001.474] 408000 not found in DVFS table
[0001.481] RamCode = 0
[0001.484] DT Write: emc-table@204000 succeeded
[0001.490] DT Write: emc-table@1600000 succeeded
[0001.494] LPDDR4 Training: Write DT: Number of tables = 2
[0001.539]
[0001.540] Debug Init done
[0001.542] Marked DTB cacheable
[0001.545] Bootloader DTB loaded at 0x83000000
[0001.550] Marked DTB cacheable
[0001.553] Kernel DTB loaded at 0x83100000
[0001.557] DeviceTree Init done
[0001.569] Pinmux applied successfully
[0001.573] gicd_base: 0x50041000
[0001.576] gicc_base: 0x50042000
[0001.579] Interrupts Init done
[0001.584] Using base:0x60005090 & irq:208 for tick-timer
[0001.589] Using base:0x60005098 for delay-timer
[0001.593] platform_init_timer: DONE
[0001.597] Timer(tick) Init done
[0001.600] osc freq = 38400 khz
[0001.604]
[0001.606] welcome to cboot
[0001.608]
[0001.609] Cboot Version: 00.00.2018.01-t210-3a168c35
[0001.614] calling constructors
[0001.617] initializing heap
[0001.620] initializing threads
[0001.623] initializing timers
[0001.626] creating bootstrap completion thread
[0001.630] top of bootstrap2()
[0001.633] CPU: ARM Cortex A57
[0001.636] CPU: MIDR: 0x411FD071, MPIDR: 0x80000000
[0001.641] initializing platform
[0001.644] Scratch reg 37 & 271 initial value set…
[0001.650] cboot:secure-pmc present
[0001.653] Manufacturer: MF = 0xc2, ID MSB = 0x25
[0001.658] ID LSB = 0x36, ID-CFI len = 194 bytes
[0001.662] Macronix QSPI chip present
[0001.666] SPI device register
[0001.669] init boot device
[0001.671] allocating memory for boot device(SPI)
[0001.676] registering boot device
[0001.685] sdmmc node status = okay
[0001.688] sdcard instance = 0
[0001.691] sdcard gpio handle 0x56
[0001.694] sdcard gpio pin 0xc9
[0001.697] sdcard gpio flags 0x0
[0001.701] vmmc-supply 0x99
[0001.703] Instance: 0
[0001.705] Allocating memory for context
[0001.709] enabling clock
[0001.711] sd card init
[0001.714] Check card present and stable
[0001.717] Send command 0
[0001.742] Send command 3
[0001.746] Set RCA for the card
[0001.749] Query card specific data by command 9
[0001.756] Parse CSD data
[0001.758] Send command 7
[0001.768] Calling sd device register
[0001.772] Init sdcard
[0001.774] Allocating memory for boot device
[0001.778] Registering user device
[0001.791] Enable APE clock
[0001.794] Un-powergate APE partition
[0001.797] of_register: registering tegra_udc to of_hal
[0001.802] of_register: registering tegra_udc to of_hal
[0001.808] of_register: registering inv20628-driver to of_hal
[0001.813] of_register: registering ads1015-driver to of_hal
[0001.819] of_register: registering lp8557-bl-driver to of_hal
[0001.825] of_register: registering bq2419x_charger to of_hal
[0001.830] of_register: registering cpc to of_hal
[0001.835] of_register: registering bq27441_fuel_gauge to of_hal
[0001.846] gpio framework initialized
[0001.849] of_register: registering tca9539_gpio to of_hal
[0001.855] of_register: registering tca9539_gpio to of_hal
[0001.860] of_register: registering i2c_bus_driver to of_hal
[0001.866] of_register: registering i2c_bus_driver to of_hal
[0001.871] of_register: registering i2c_bus_driver to of_hal
[0001.877] of_register: registering i2c_bus_driver to of_hal
[0001.882] pmic framework initialized
[0001.886] of_register: registering max77620_pmic to of_hal
[0001.891] regulator framework initialized
[0001.895] of_register: registering tps65132_bl_driver to of_hal
[0001.901] initializing target
[0001.907] gpio_driver_register: register ‘tegra_gpio_driver’ driver
[0001.916] fixed regulator driver initialized
[0001.932] initializing OF layer
[0001.935] NCK carveout not present
[0001.939] Skipping dts_overrides
[0001.943] of_children_init: Ops found for compatible string nvidia,tegra210-i2c
[0001.959] I2C Bus Init done
[0001.962] of_children_init: Ops found for compatible string nvidia,tegra210-i2c
[0001.972] I2C Bus Init done
[0001.975] of_children_init: Ops found for compatible string nvidia,tegra210-i2c
[0001.985] I2C Bus Init done
[0001.988] of_children_init: Ops found for compatible string nvidia,tegra210-i2c
[0001.998] I2C Bus Init done
[0002.001] of_children_init: Ops found for compatible string nvidia,tegra210-i2c
[0002.011] I2C Bus Init done
[0002.014] of_children_init: Ops found for compatible string maxim,max77620
[0002.024] max77620_init using irq 118
[0002.029] register ‘maxim,max77620’ pmic
[0002.033] gpio_driver_register: register ‘max77620-gpio’ driver
[0002.039] of_children_init: Ops found for compatible string nvidia,tegra210-i2c
[0002.049] I2C Bus Init done
[0002.053] NCK carveout not present
[0002.056] shim_invoke: No NCT, Calling dts updates
[0002.067] Find /i2c@7000c000’s alias i2c0
[0002.071] get eeprom at 1-a0, size 256, type 0
[0002.080] Find /i2c@7000c500’s alias i2c2
[0002.084] get eeprom at 3-a0, size 256, type 0
[0002.088] get eeprom at 3-ae, size 256, type 0
[0002.093] pm_ids_update: Updating 1,a0, size 256, type 0
[0002.098] I2C slave not started
[0002.101] I2C write failed
[0002.104] Writing offset failed
[0002.107] eeprom_init: EEPROM read failed
[0002.111] pm_ids_update: eeprom init failed
[0002.115] pm_ids_update: Updating 3,a0, size 256, type 0
[0002.145] pm_ids_update: The pm board id is 3448-0000-200
[0002.152] Adding plugin-manager/ids/3448-0000-200=/i2c@7000c500:module@0x50
[0002.159] pm_ids_update: pm id update successful
[0002.164] pm_ids_update: Updating 3,ae, size 256, type 0
[0002.169] I2C slave not started
[0002.172] I2C write failed
[0002.175] Writing offset failed
[0002.178] eeprom_init: EEPROM read failed
[0002.182] pm_ids_update: eeprom init failed
[0002.212] eeprom_get_mac: EEPROM invalid MAC address (all 0xff)
[0002.218] shim_eeprom_update_mac:267: Failed to update 0 MAC address in DTB
[0002.226] eeprom_get_mac: EEPROM invalid MAC address (all 0xff)
[0002.232] shim_eeprom_update_mac:267: Failed to update 1 MAC address in DTB
[0002.240] updating /chosen/nvidia,ethernet-mac node 00:04:4b:e4:11:e8
[0002.247] Plugin Manager: Parse ODM data 0x00094000
[0002.256] shim_cmdline_install: /chosen/bootargs: root=/dev/mmcblk0p1 rw rootwait rootfstype=ext4 console=ttyTHS1,115200n8 console=tty0 fbcon=map:0 net.ifnames=0
[0002.278] Find /i2c@7000c000’s alias i2c0
[0002.282] get eeprom at 1-a0, size 256, type 0
[0002.290] Find /i2c@7000c500’s alias i2c2
[0002.294] get eeprom at 3-a0, size 256, type 0
[0002.299] get eeprom at 3-ae, size 256, type 0
[0002.303] pm_ids_update: Updating 1,a0, size 256, type 0
[0002.308] I2C slave not started
[0002.311] I2C write failed
[0002.314] Writing offset failed
[0002.317] eeprom_init: EEPROM read failed
[0002.321] pm_ids_update: eeprom init failed
[0002.325] pm_ids_update: Updating 3,a0, size 256, type 0
[0002.355] pm_ids_update: The pm board id is 3448-0000-200
[0002.362] Adding plugin-manager/ids/3448-0000-200=/i2c@7000c500:module@0x50
[0002.369] pm_ids_update: pm id update successful
[0002.373] pm_ids_update: Updating 3,ae, size 256, type 0
[0002.379] I2C slave not started
[0002.382] I2C write failed
[0002.384] Writing offset failed
[0002.387] eeprom_init: EEPROM read failed
[0002.391] pm_ids_update: eeprom init failed
[0002.421] Chip UID is 000000016441b744100000000a050340
[0002.426] Add serial number:04212190231000400305 as DT property
[0002.435] Applying platform configs
[0002.441] platform-init is not present. Skipping
[0002.446] calling apps_init()
[0002.465] Found 14 GPT partitions in “sd0”
[0002.469] Proceeding to Cold Boot
[0002.473] starting app android_boot_app
[0002.476] Device state: unlocked
[0002.480] display console init
[0002.488] could not find regulator
[0002.491] hdmi cable connected
[0002.494] I2C slave not started
[0002.497] I2C write failed
[0002.500] Writing offset failed
[0002.503] could not read edid
[0002.509] tmds-config node not found
[0002.513] pmc_set_io_pad_voltage: Error -2 retrieving platform-io-pad-voltagepropsetting ‘avdd-io-hdmi-dp’ regulator to 1050000 micro volts
[0002.529] DT entry for leds-pwm not found
[0002.533] setting ‘vdd-1v8’ regulator to 1800000 micro volts
[0002.541] could not find regulator
[0002.544] could not find regulator
[0002.547] could not find regulator
[0002.575] using default cmu settings
[0002.579] dc_hdmi_enable, starting HDMI initialisation
[0002.586] dc_hdmi_enable, HDMI initialisation complete
[0002.591] list and configure display window
[0002.595] display console init completed
[0002.603] subnode volume_up is not found !
[0002.606] subnode back is not found !
[0002.610] subnode volume_down is not found !
[0002.614] subnode menu is not found !
[0002.618] Gpio keyboard init success
[0002.663] found decompressor handler: lz4-legacy
[0002.678] decompressing blob (type 1)…
[0002.711] load_bmp_blob: panelresolution=480 type=0
[0002.764] decompressor handler not found
[0002.768] load_firmware_blob: Firmware blob loaded, entries=2
[0002.773] se_aes_verify_sbk_clear: Error
[0002.777] bl_battery_charging: connected to external power supply
[0002.784] xusb is supported
[0002.790] error while finding nvidia,portmap
[0002.796] could not find regulator
[0003.299] xusb blob version 0 size 124416
[0003.303] firmware size 124416
[0003.308] Firmware timestamp: 0x5cd2a472, Version: 50.22 release
[0003.316] xhci0: 64 bytes context size, 32-bit DMA
[0003.356] usbus0: 5.0Gbps Super Speed USB v3.0
[0003.376] uhub0: <Nvidia XHCI root HUB, class 9/0, rev 3.00/1.00, addr 1> on usbus0
[0004.026] uhub0: 9 ports with 9 removable, self powered
[0005.026] failed to get HID devices
[0005.029] failed to init xhci or no usb device attached
[0008.037] Power button long press detected
[0008.041] Entering fastboot mode…
[0008.044] starting fastboot mode
[0008.048] fastboot cmd_init done.
[0008.052] platform does not support off-mode-charge
[0008.056] usbdcd_init Initialize USBF driver
[0008.061] usbdcd_phy_open oscfreq = 5
[0008.070] usbdcd_start Start the initialized controller
[0008.076] get_fastb-- suspend –
o[0008.079] ot_instructions: Error -2 finding instructions in /chosen
[0008.101] Key Code 8 not handled
[0008.304] Key Code 8 not handled
[0008.507] Key Code 8 not handled

[0008.101] Key Code 8 not handled
[0008.304] Key Code 8 not handled
[0008.507] Key Code 8 not handled

Finally, nano will always print “Key Code 8 not handled” !

on board:
SLEEP/WAKE* connect to GND ;
POWER_EN pull up to +5V;
SYS_RESET* and MOD_SLEEP* output high 1.8V .

Is there any other pin that need attention ?

Thanks!

Hi, WayneWWW

@yzh03 is my colleague. Add some more information here.

L4T: R32.2
Kernel: 4.9.140

  1. There is no EEPROM on our board.
    We refer to this topic https://devtalk.nvidia.com/default/topic/1061344/jetson-nano/the-problem-for-carrier-board-customization/post/5376783/#5376783and know that it can work properly without EEPROM.

  2. There is no power management chip ina3221 on our board.
    Im not sure that is the reason why our carrier board isnt working properly without ina3221 ? For the TX2, we also made the carrier board, there is no power management chip, but it does not affect the system startup, and just only affects usb.

Hi Ethan/yzh03,

I think it is more like a hardware design problem. The bootloader detects the gpio key event and thus enter fastboot.
However, it does not happen on our devkit.

Thanks WayneWWW,
I think it is like the hardware gpio key event , but don’t know which gpio is matter to nano startup and print the message (except SLEEP/WAKE* , POWER_EN, SYS_RESET* which specified in datasheet).

it boots when PU SLEEP/WAKE* to +1.8V

I’m having the same problem on our custom board. It doesn’t happen on a cold boot, but if I run “reboot” or if the kernel crashes for some reason, this happens. I am using a Jetson Nano with a custom carrier board. Is there a specific pin I should pull high/low?

Hi Shadowmind,

Please help to open a new topic for your issue. Thanks