Power LED of AGX Xavier dev-kit does not glow to set the in recovery mode, and cannot detect USB-C. What is the problem?

I have an AGX Xavier dev-kit. I flashed jetpack 4.1 last week. It was fine. Now, I am trying to flash jetpack 4.3 in it. Initially, I kept the power off. Only the USB-C to USB-A cable is connected. First of all, SDK manager does not detect the target hardware even after pressing refresh for multiple times. Before flashing it, as I want to change from jetpack 4.1 to jetpack 4.3, I kept the power of the dev-kit off. Then, I pressed the recovery button and the start button and held for a few seconds. The last time when I installed jetpack4.1, the power LED became on after this step. But it did not happen this time. However, if i manually turn on the dev-kit just by pressing the power button (power supply connected), it boots. I am not sure, why the recovery mode is not functining. Your help is highly appreciated.

If you can still boot into ubuntu desktop, you can use the command “sudo reboot forced-recovery” to put device into recovery mode. Please try.


I did as you suggested. But then, the connecting display goes off, but the power LED remains white. Then, to flash the memory of the AGX Xavier, I turned the power supply off. Then, pressed recovery and the power button together and held for a few seconds. The LED did not glow. I repeated it, but nothing happens.

Please suggest how to resolve this issue.



I did as you suggested. But then, the connecting display goes off,

This is under expectation. OS will be gone when you try to enter recovery mode.

Then, to flash the memory of the AGX Xavier, I turned the power supply off.

Why did you do that? Why did you turn off the power again? What we want to try is use software command to put device into recovery mode and see if it can still get flash.

Thus, what you should do after you see display goes off is connecting the flash cable, check lsusb and try flash command.

Okay. In all the resoruces that I found they said, before flashing the memory, the main power supply should go off. However, I noticed the following.

When I reboot in recovery mode, as you suggested, or if the device is off and then I keep the power supply on and then press the recovery+ power button, lsusb shows nvidia … which indicates the recovery mode. I was not sure whether I should continue and flash while the power is ON.

To summarize, are you asking me to kwwp the power supply on -> take the device to recovery mode-> Flash?
Please confirm…

thank you,


There are few ways to put device into recovery mode on devkit.
When you finish one of them, you do not need to try other one anymore.

method 1. If device is ON and OS is running, find a keyboard and type

sudo reboot forced-recovery

after it, device should be going to recovery mode and OS will be gone.

method 2. If device is not power on, then press recovery mode button, press the power button, release the power button, and release the recovery mode button.

method3. If device is still ON, but you don’t want to use method1. Then you just need to do method2 again but replace all the power button with reset button.

For your current problem, it sounds like you tried method 2/3 already but you failed to flash. Thus, what I suggested is method1.

And after method 1 is done, what you need to do is confirm board is in recovery mode and directly flash it. You should not do method 2 again.

Thank you for the responses. I tried method 1 and things started to work. However, there were a lot of failure installations of various components such as Vision works, NVIDIA Container Runtime, Deepstream etc. One of the typical errors is attached. Can I install them separately once the OS is loaded at least?


Installing sdk component and flashing board could be done separately.

I think this issue only focuses on the flash process. Could you confirm if the board is able to go through the flash process first?

Please note that you can use flash.sh script instead of sdkmanager to save your time if we only want to test the flash.

You can check how to use flash.sh by reading the quick start guide from dlc.