Pretrained TrafficCamNet model gives very bad accuracy on Jetson Xavier NX

Please provide complete information as applicable to your setup.

**• Hardware Platform (Jetson / GPU) Jetson Xavier NX
**• DeepStream Version l4t-5.1-triton
• Issue Type( questions, new requirements, bugs) bugs

1. How to reproduce the issue ? (This is for bugs. Including which sample app is using, the configuration files content, the command line used and other details for reproducing)
Hi, Deepstream TrafficCamnet work very well on RTX 2080ti, But, The same etlt model gives us very bad accuracy on our Jetson Xavier NX.

  • Step 1: Download pruned TrafficCamNet etlt model from nvidia NGC
  • Step 2. Using tao-converter (for Jetson and DS5.1) to convert .etlt model to .engine model.
    Uploading: trafficnet_int8.txt…
 ./tao-converter resnet18_trafficcamnet_pruned.etlt -k tlt_encode -d 3,544,960 -o output_cov/Sigmoid,output_bbox/BiasAdd -c trafficnet_int8.txt -e resnet34_int8_jetson.engine -m 16 -t int8

  • Step 3. Deploy on DS

2. Requirement details( This is for new requirement. Including the module name-for which plugin or for which sample application, the function description)

  • The attached file includes: tao-converter, ds_config_file, …

Your help will help us a lot. Please tell me if you need more information.
Thank you.
tao-converter (122.2 KB)
dstest_pgie_config.txt (766 Bytes)

trafficnet_int8.txt (4.8 KB)

Which mode did you run, int8 or fp16?
From the config file,
model-engine-file=/ws/intrusion_detections/streaming/app/models/resnet34_fp16_jetson.engine

But the tao-converter is generating an int8 engine.

Hi @Morganh I tried both fp16 and int8. The results are still very bad.

To narrow down, please focus on fp16 firstly.
You can directly let deepstream generate tensort engine. Not use the tao-converter.

tlt-model-key=tlt_encode
tlt-encoded-model=…/…/models/tlt_pretrained_models/trafficcamnet/resnet18_trafficcamnet_pruned.etlt

For trafficacamnet, there is already config file.

Refer to samples/configs/tlt_pretrained_models/config_infer_primary_trafficcamnet.txt

Thanks. I will do it and let you know soon

still got the same result.
dstest_pgie_config.txt (2.1 KB)

TrafficCamNet did very well on RTX 2080ti (for all type: int8, fp16 and fp32). jetson is so bad
Screenshot from 2022-07-07 13-58-42
Screenshot from 2022-07-07 13-54-58

What is the tensorrt version in your RTX2080ti and Jetson?
$ dpkg -l |grep cuda

RTX 2080ti: 8016 (ds 6.1 triton)
Jetson xavier NX: (7210) (ds5.1 triton)

Should we try to use DS 6.1 on jetson also?

Sure, need to update to latest Jetpack.

Yes. Got it.
I will be back in tomorrow.
Thank you

Hi @Morganh. DS 6.1 have the same result (bad).
Command to convert:

./tao-converter resnet18_trafficcamnet_pruned.etlt -k tlt_encode -d 3,544,960 -o output_cov/Sigmoid,output_bbox/BiasAdd -c trafficcamnet_int8.txt -e resnet18_int8_jetson.engine -m 8 -t int8

dstest_pgie_config.txt (2.1 KB)

dstest_tracker_config.txt (227 Bytes)
tao-converter (128.6 KB)
resnet18_int8_jetson.engine (2.3 MB)

Solved. Running with sample code from nvidia give good accurary. Thank for your help @Morganh

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.