Prevent kernel timeout on second CUDA device

Dear all,

I know that the OS does prevent too long kernel execution times by canceling an execution with a timeout-failure. I also know that—on a desktop machine—one should get a second CUDA device if possible as then the first may still be used uninterrupted by the Window manager of the OS. However, I now do have a second CUDA device (second 8800GT in a Mac Pro) but this one still has it’s kernelExecTimeout enabled (as cudaGetDeviceProperties(…) tells me).

How can I disable the kernel exec timeout under OS X and use my second 8800GT solely for computation purposes? Ideally, I would configure the same behaviour for both CUDA and OpenCL.

Thanks!

nodag