Preventing monitor shutdown in virtual terminal


Tried this on the Ubuntu forums, but no reply. Hopefully someone here can help! I’m a CUDA and GPU computing newbie, as may become obvious…

How can I prevent automatic monitor switch-off (or whatever it’s called… when you’ve been inactive for some minutes and your computer stops sending output to your screen) when I’m in a virtual terminal session, with X stopped? In the Ubuntu desktop settings, I’ve told it never to switch the screen off, but this doesn’t seem to apply when in a virtual terminal/not in the Ubuntu (11.10) GUI. Not sure how to get at these settings from the terminal! Any help very much appreciated. Or, would it be easier just to use my motherboard’s on-board graphics and have the GeForce card just for doing my computing job as described in this thread?

I’m running a program on my GPU (GeForce GTX 275) using PyCUDA on Ubuntu 11.10. For my GPU to be useable, I have to go into a virtual terminal and stop X before running the PyCUDA stuff it seems. Problems arise when the terminal thinks it has been inactive for a while (i.e. I have not typed anything), so stops sending stuff to my monitor. This interrupts the PyCUDA program and causes it to fail. I can sit at my computer and press keys every so often to prevent this, but the program takes quite a long time and I’d rather not sit in front of my computer all day…

Ah, I was being a total linux terminal n00b. Screensaver activation prevention:

$ setterm -powersave off -blank 0