Problem adding cufft to a current project cudaError in memory location X on startup when linking to

Hi All

I have code running in my program, which functions as intended at the moment. I want to include some data interpolation using an fft, and have this running in a test program as well. So both are doing fine seperately.

When I add cufft to my main program linker, I get a “cudaError at memory location 0xsomething” before any of my breakpoints trigger, i.e. it is not my code as such but some automatic loading of DLL’s etc that I can’t control.

I’m using CUDA 3.2
MS Visual Studio 2008 SP1, using MFC
The system runs on a GTX480
I’m linking ‘cuda.lib’, ‘cudart.lib’, and ‘cufft.lib’ in the project, using the 32-bit releases.
My platform is Windows 7 64-bit

As I said, it has worked fine before and by itself. But together it fails.

Has anybody had any similar experiences or any clues on to how it can be fixed?


Henrik Andresen

I tried installing the CUDA Toolkit 4.0 RC2, and this removed the problem.