Problem deploying with bootstrap.sh

Hi,

I’m having some problems deploying Clara via the boostrap script (v0.5.0-2004.7).

Firstly, I’ve managed to successfully install it and get it running on one machine (Ubuntu 18.04). I’m now trying to get it installed on a second machine, same OS and similar spec but with a slightly higher spec GPU so I can use the render service.

However, on this second machine the boostrap script always fails after the master node initialisation section when it tries to create the “user” .kube/config folders.

I am following the instructions to the letter and running the script via “sudo”.

FYI, I have rebooted the machine at several points, run the uninstall script first and various combinations of both without success. I have also manually edited the script at various points to test. It appears to be some permission issue.

Below is a snipped of the scripts output, around the point of failure.

I’d really like some help in getting this up and running, I’ve spent some time playing around but just can’t get it to got, it is particularity frustrating given it is running fine on a very similar machine!

[bootstrap-token] Configuring bootstrap tokens, cluster-info ConfigMap, RBAC Roles
[bootstrap-token] configured RBAC rules to allow Node Bootstrap tokens to post CSRs in order for nodes to get long term certificate credentials
[bootstrap-token] configured RBAC rules to allow the csrapprover controller automatically approve CSRs from a Node Bootstrap Token
[bootstrap-token] configured RBAC rules to allow certificate rotation for all node client certificates in the cluster
[bootstrap-token] Creating the "cluster-info" ConfigMap in the "kube-public" namespace
[addons] Applied essential addon: CoreDNS
[addons] Applied essential addon: kube-proxy

Your Kubernetes control-plane has initialized successfully!

To start using your cluster, you need to run the following as a regular user:

  mkdir -p $HOME/.kube
  sudo cp -i /etc/kubernetes/admin.conf $HOME/.kube/config
  sudo chown $(id -u):$(id -g) $HOME/.kube/config

You should now deploy a pod network to the cluster.
Run "kubectl apply -f [podnetwork].yaml" with one of the options listed at:
  https://kubernetes.io/docs/concepts/cluster-administration/addons/

Then you can join any number of worker nodes by running the following on each as root:

kubeadm join 138.194.48.49:6443 --token 0pik8k.gqqo83lzeomjjh6s \
    --discovery-token-ca-cert-hash sha256:acf5394071bf7f24ee5ef82ce613fb33640d33609ae27780c4e82bfab3e705b9 
mkdir: cannot create directory ‘/root’: Permission denied

Regards,

Darren Thompson

I think the script is broken. It broke for me too. I can’t understand why it ever worked for anybody!

After the ‘sudo cp /etc/kubernetes/admin.conf’ line try adding
sudo chown -R $SUDO_USER $HOME/.kube

Also the following line always fails for me, ‘kubectl apply -f $SCRIPT_DIR/kube-flannel.yml’
because SCRIPT_DIR is used wrongly. I just remove $SCRIPT_DIR/ then it worked.
Same for the line after that too.