Problem driver Nvidia Geforce GTX 1650 in ubuntu 20.04 kernel - 5.8.0-44-generic

Good afternoon,

I have a problem with the drivers for the video card on my laptop.
At the end of 2020, I purchased a Lenovo IdeaPad Gaming 3 15ARH05 laptop.
Install the linux installation system ubuntu 20.04-kernel 5.8.0-44-generic.
This laptop has an Nvidia Geforce GTX 1650 graphics card. Unfortunately, no divers are installed on this video card. What I tried:

  1. This is an interactive installation via software & updates (official drivers) of all available drivers in turn (first installed, then removed).
  2. Install via from the PPA repository via the sudo add-apt-repository ppa command:graphics-drivers/ppa and installation of divers that you recommend for my video card
  3. Download and install in manual mode. downloaded from the link Загрузка драйверов NVIDIA . I chose for a laptop (Geforce-Geforce GTX 16 Seires (Notebook) - Geforce GTX 1650-Production Branch-English (US)). During installation, an error occurred and pointed to the log - /var/log/nvidia-installer. log. Looking in the log, I found the first error of the form /tmp/selfgz15188/NVIDIA-Linux-x86_64-430.50/kernel/common/inc/nv-linux. h:515:17: error: too many arguments to function ‘__vmalloc’
    515 | void *ptr = __vmalloc(size, GFP_KERNEL, PAGE_KERNEL);
    | ^~~~~~~~~
    Everything is relative to this method
  4. I tried to install drivers with CUDA - installing drivers 11.2 comes with drivers included. Unfortunately, it didn’t go well either.

Please advise me what to do so that on my laptop I can put your drivers on the video card and work safely. Thank you in advance for the quickest response.

nvidia-installer.txt (2.4 MB)
this is the log file that I got from step 3

Please uninstall the runfile driver using the --uninstall option, afterwards use option 2) again to install drivers. Then run nvidia-bug-report.sh as root and attach the resulting nvidia-bug-report.log.gz file to your post.

I ran NVIDIA-Linux-x86_64-430.09. run with the flag: sudo bash NVIDIA-Linux-x86_64-430.09.run --uninstall. But I don’t understand about which file nvidia-bug-report.sh there is a speech …

It’s installed alongside the driver in the normal path.

I create a folder: mkdir -p test_nvidia** I go to the folder: ** cd test_nvidia
I transfer the installation file there and check for availability
mv ../NVIDIA-Linux-x86_64-430,09.run . && ls** ** NVIDIA-Linux-x86_64-430,09.run
Running the installation: sudo bash NVIDIA-Linux-x86_64-430.09. run** No file nvidia-bug-report.sh I don't see it next to the installer. I go to the linux root and search for this file: ** cd / & & sudo find . -iname "nvidia-bug-report.sh"
The search is empty. What file are you talking about? I only get the log file, which I attach again for you.

nvidia-installer.log (2.5 MB)

And log uninstall nvidia

nvidia-uninstall.log (435 Bytes)

Install the driver from ppa. Then the script will appear.

I run:

  1. sudo add-apt-repository ppa:graphics-drivers/ppa
  2. sudo apt install nvidia-driver-430
  3. sudo nvidia-bug-report.sh
    Create file - nvidia-bug-report.log.gz
    nvidia-bug-report.log.gz (235.9 KB)

and I run command:
4. nvidia-smi
and received: NVIDIA-SMI has failed because it couldn’t communicate with the NVIDIA driver. Make sure that the latest NVIDIA driver is installed and running.

Please do all of this:

  • delete /etc/X11/xorg.conf
  • remove “nomodeset” kernel parameter
  • disable secure boot in bios

If it still doesn’t work, please create a new nvidia-bug-report.log.

1 Like

Thank you very much for your help. How do I mark your help ? Where to put 5 stars out of 5 ?