Problem facing on Live feed using HTTPS URI of the camera

Hii,
I am working on live stream video analytics on deepstream. I have the https uri of the camera. When I use that uri directly in deepstream text file it is showing the error stating that stream does not have enough data. Please help me to sort out the error.
Jetson nano Information:
NVIDIA Jetson Nano (Developer Kit Version)
L4T 32.5.1 [ JetPack UNKNOWN ]
Ubuntu 18.04.5 LTS
Kernel Version: 4.9.201-tegra
CUDA 10.2.89
CUDA Architecture: 5.3
OpenCV version: 4.1.1
OpenCV Cuda: NO
CUDNN: 8.0.0.180
Deepstream: 5.1
TensorRT: 7.1.3.0
Vision Works: 1.6.0.501
VPI: ii libnvvpi1 1.0.15 arm64 NVIDIA Vision Programming Interface library

Output Log:
vamsisiddharthasiddhu2041@linux:/opt/nvidia/deepstream/deepstream-5.1/samples/configs/tlt_pretrained_models$ deepstream-app -c deepstream_app_source1_peoplenet.txt
gstnvtracker: Loading low-level lib at /opt/nvidia/deepstream/deepstream-5.1/lib/libnvds_mot_klt.so
gstnvtracker: Optional NvMOT_RemoveStreams not implemented
gstnvtracker: Batch processing is OFF
gstnvtracker: Past frame output is OFF
WARNING: [TRT]: Using an engine plan file across different models of devices is not recommended and is likely to affect performance or even cause errors.
0:00:11.133104231 7796 0x39166610 INFO nvinfer gstnvinfer.cpp:619:gst_nvinfer_logger:<primary_gie> NvDsInferContext[UID 1]: Info from NvDsInferContextImpl::deserializeEngineAndBackend() <nvdsinfer_context_impl.cpp:1702> [UID = 1]: deserialized trt engine from :/opt/nvidia/deepstream/deepstream-5.1/samples/models/peoplenet/resnet34_peoplenet_pruned.etlt_b1_gpu0_fp16.engine
INFO: [Implicit Engine Info]: layers num: 3
0 INPUT kFLOAT input_1 3x544x960
1 OUTPUT kFLOAT output_bbox/BiasAdd 12x34x60
2 OUTPUT kFLOAT output_cov/Sigmoid 3x34x60

0:00:11.133326941 7796 0x39166610 INFO nvinfer gstnvinfer.cpp:619:gst_nvinfer_logger:<primary_gie> NvDsInferContext[UID 1]: Info from NvDsInferContextImpl::generateBackendContext() <nvdsinfer_context_impl.cpp:1806> [UID = 1]: Use deserialized engine model: /opt/nvidia/deepstream/deepstream-5.1/samples/models/peoplenet/resnet34_peoplenet_pruned.etlt_b1_gpu0_fp16.engine
0:00:11.159886894 7796 0x39166610 INFO nvinfer gstnvinfer_impl.cpp:313:notifyLoadModelStatus:<primary_gie> [UID 1]: Load new model:/opt/nvidia/deepstream/deepstream-5.1/samples/configs/tlt_pretrained_models/config_infer_primary_peoplenet.txt sucessfully

Runtime commands:
h: Print this help
q: Quit

    p: Pause
    r: Resume

NOTE: To expand a source in the 2D tiled display and view object details, left-click on the source.
To go back to the tiled display, right-click anywhere on the window.

**PERF: FPS 0 (Avg)
**PERF: 0.00 (0.00)
** INFO: <bus_callback:181>: Pipeline ready

**PERF: 0.00 (0.00)
**PERF: 0.00 (0.00)
**PERF: 0.00 (0.00)
ERROR from source: Bad Luck
Debug info: gstsouphttpsrc.c(1431): gst_soup_http_src_parse_status (): /GstPipeline:pipeline/GstBin:multi_src_bin/GstBin:src_sub_bin0/GstURIDecodeBin:src_elem/GstSoupHTTPSrc:source:
Bad Luck (403), URL: https://rec10.cloud.smartmonitoring.jio.com/flv/live?access_token=801-U_censored_6606c&vcodec=h264&ts=1628655013.4&o=801000025995&server=801-TOmoNNC1vYmsVEzRZktPMM&q=1&camera=0&streams=video&duration=1200&u=801000022155&acodec=aac&token=5f9a5629b995c262d95187637207b4a7, Redirect to: (NULL)
ERROR from source: Internal data stream error.
Debug info: gstbasesrc.c(3055): gst_base_src_loop (): /GstPipeline:pipeline/GstBin:multi_src_bin/GstBin:src_sub_bin0/GstURIDecodeBin:src_elem/GstSoupHTTPSrc:source:
streaming stopped, reason error (-5)
ERROR from typefindelement0: Stream doesn’t contain enough data.
Debug info: gsttypefindelement.c(996): gst_type_find_element_chain_do_typefinding (): /GstPipeline:pipeline/GstBin:multi_src_bin/GstBin:src_sub_bin0/GstURIDecodeBin:src_elem/GstTypeFindElement:typefindelement0:
Can’t typefind stream
Quitting
App run failed

I am enclosing the screenshot of the error. Please help me to sort out the error.
Thanks in advance…

Hi,
Not sure if HTTP path works in uridecodebin. Please try to run gst-launch-1.0 command:

$ gst-launch-1.0 uridecodebin uri=_HTTP_URI_ ! nvoverlaysink

It it does not work in urodecodebin, may try this souphttpsrc

You would need to work out a working pipeline in gst-launch-1.0 first.

Not working. Getting error.
output log:
vamsisiddharthasiddhu2041@linux:/opt/nvidia/deepstream/deepstream-5.1/samples/configs/tlt_pretrained_models$ gst-launch-1.0 uridecodebin uri=https://rec10.cloud.smartmonitoring.jio.com/flv/live?access_token=801-U_censored_3cca3&vcodec=h264&ts=1628664081.0&o=801000025995&server=801-TOmoNNC1vYmsVEzRZktPMM&q=1&camera=0&streams=video&duration=1200&u=801000022155&acodec=aac&token=4acf9de426210d17df21e3d6b9c96f99https://rec10.cloud.smartmonitoring.jio.com/flv/live?access_token=801-U_censored_3cca3&vcodec=h264&ts=1628664081.0&o=801000025995&server=801-TOmoNNC1vYmsVEzRZktPMM&q=1&camera=0&streams=video&duration=1200&u=801000022155&acodec=aac&token=4acf9de426210d17df21e3d6b9c96f99 ! nvoverlaysink
[1] 7074
[2] 7075
[3] 7076
[4] 7077
[5] 7078
[6] 7079
[7] 7080
[8] 7081
[9] 7082
[10] 7083
[11] 7084
[12] 7085
[13] 7086
[14] 7087
[15] 7088
[16] 7089
[17] 7090
[18] 7091
[19] 7092
[20] 7093
[21] 7094
[22] 7095
-bash: !: command not found
[2] Done vcodec=h264
[3] Done ts=1628664081.0
[4] Done o=801000025995
[5] Done server=801-TOmoNNC1vYmsVEzRZktPMM
[6] Done q=1
[7] Done camera=0
[8] Done streams=video
[9] Done duration=1200
[10] Done u=801000022155
[11] Done acodec=aac
[12] Done token=4acf9de426210d17df21e3d6b9c96f99https://rec10.cloud.smartmonitoring.jio.com/flv/live?access_token=801-U_censored_3cca3
[13] Done vcodec=h264
[14] Done ts=1628664081.0
[15] Done o=801000025995
[16] Done server=801-TOmoNNC1vYmsVEzRZktPMM
[17] Done q=1
[18] Done camera=0
[19] Done streams=video
[20] Done duration=1200
[21] Done u=801000022155
[22]+ Done acodec=aac
vamsisiddharthasiddhu2041@linux:/opt/nvidia/deepstream/deepstream-5.1/samples/configs/tlt_pretrained_models$ Setting pipeline to PAUSED …
Pipeline is PREROLLING …
Got context from element ‘source’: gst.soup.session=context, session=(SoupSession)NULL, force=(boolean)false;
ERROR: from element /GstPipeline:pipeline0/GstURIDecodeBin:uridecodebin0/GstSoupHTTPSrc:source: Bad request
Additional debug info:
gstsouphttpsrc.c(1433): gst_soup_http_src_parse_status (): /GstPipeline:pipeline0/GstURIDecodeBin:uridecodebin0/GstSoupHTTPSrc:source:
Bad request (400), URL: https://rec10.cloud.smartmonitoring.jio.com/flv/live?access_token=801-U_censored_3cca3, Redirect to: (NULL)
ERROR: pipeline doesn’t want to preroll.
Setting pipeline to NULL …
Freeing pipeline …

[1]+ Exit 1 gst-launch-1.0 uridecodebin uri=https://rec10.cloud.smartmonitoring.jio.com/flv/live?access_token=801-U_censored_3cca3

Hi,
You would need to try pipeline with opensource components first and make sure it works. May try souphttpsrc like:

$ gst-launch-1.0 souphttpsrc ! fakesink

Instead of nvoverlaysink please try xvimagesink or autovideosink:

$ gst-launch-1.0 uridecodebin ! xvimagesink
$ gst-launch-1.0 uridecodebin ! autovideosink