Problem flashing ORIN NX

I tried flashing the Jetson Orin NX to boot from a NVMe memory following the instructions here:

After some preliminaries, I execute the command:

sudo ./tools/kernel_flash/ --external-device nvme0n1p1 \
  -c tools/kernel_flash/flash_l4t_external.xml -p "-c bootloader/t186ref/cfg/flash_t234_qspi.xml" \
  --showlogs --network usb0 p3509-a02+p3767-0000 internal

Looks like the flashing scripts proceeds until it eventually waits for the Jetson to reboot, and after some time waiting without any success, the script exits without completing the procedure. The jetson does not boot up into the OS.
I also tried flashing the nvme externally and then inserting it into the Jetson as explained here, but still the Jetson does not boot up to anything.
I’m suspecting that the bootloader does not get correctly flashed and the Jetson does not even try to load the system from the nvme.
What am I doing wrong?

Hi ecuniato,

Are you using the devkit or custom board?

Why you use p3509-a02+p3767-0000 as your board config?
Are you using Orin NX module + Xavier NX devkit carrier board?

Please provide the flash log for further check.

Hi KevinFFF, thanks for your reply.

I’m using this custom carrier board with a production Jetson Orin NX module. The carrier board is fully functional since I successfully flashed a Xavier NX Jetson using the Nvidia SDK Manager (unfortunately the same SDK does not support yet the Orin NX, hence why I have to do this by command line). I am not using the Xavier NX devkit carrier board.

I’m using p3509-a02+p3767-0000 as my board config since this looks like the config for Orin NX modules according to this table. Is the config also dependent on the carrier board or only on the Jetson module? If it depends on the carrier board, how can I find the right config file for my situation?

Please find attached the flash log.
log.txt (232.9 KB)

I have exactly the same problem with my custom carrier board.

initrd flash depends on the carrier board. Please share your uart log during flash.

EEPROM is an optional component for a customized carrier board.
If the carrier board is designed without an EEPROM, the following modifications will be needed on the MB2 BCT file:

  • cvb_eeprom_read_size = <0x100>
  • cvb_eeprom_read_size = <0x0>

Fixed my problem. Thanks very much!

1 Like

Me too,and flash log is the same.

Hi,i modified this dts file,and finished write BSP,but my Orin NX no HDMI output,did you changed other dts files?

I had the same problem as ‘ecuniato’ with the Auvidea JNX42 carrier and the answer from ‘chatnis’ solved the problem for me too.
Thank you.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.