Problem for compiling Mpich 1.2.7p1 with PGI 6.2.3 64 bits


I’ve just installed PGI 6.2.3 64 bits under CentOS 4.4 64 bits, and tested successfully the compilation of your examples.

I’m trying to compile and install Mpich 1.2.7p1 but I’ve got some problems. I configured it as you advise :

env CFLAGS="-fast" CXXFLAGS="-fast" FFLAGS="-fast" F90FLAGS="-fast" LDFLAGS="-fast" \
 OPTFLAGS="-fast"  CC="pgcc" CXX="pgCC"  F90="pgf90"  FC="pgf77"  CPP="pgCC -E" \
 ./configure --prefix=/usr/local/mpich-1.2.7p1

When I run “make”, I get these error messages :

/root/install/mpich-1.2.7p1/bin/mpif77 -fast  -o fxgraphics fxgraphics.o -L/root/install/mpich-1.2.7p1/lib -lmpe -L/usr/X11R6/lib -lX11   -lm
/usr/bin/ld: escamotage incompatible /usr/X11R6/lib/ lors de la recherche de -lX11
/usr/bin/ld: escamotage incompatible /usr/X11R6/lib/libX11.a lors de la recherche de -lX11
/usr/bin/ld: can't find -lX11
make[4]: *** [fxgraphics] error 2
** Fortran77 application CANNOT be linked with graphics library

I think this is caused by a compatibility problem between the 32-bits library and the 64-bits one.

How can I tell the compiler to use the 64-bits libraries ?

Thank you !

Hi Benji,

You need to set the “-L” flag to your system’s 64-bit X11 libraries, “-L/usr/X11R6/lib64”.

  • Mat

Thank you, I used -L/usr/X11R6/lib64 and -L/usr/lib64 and it worked.