Problem in Installing DIGITS

Dear All,

Good Evening !!

I’m Amitava from India. I’ve beeb facing some problem while installing NVIDIA DIGITS

I’ve followed the steps mentioned in https://github.com/dusty-nv/jetson-inference#system-setup

But finally running ./dgit-devserver it gives the error


| _ / | | / |
| |) | | (
|| | | | _

|
/_|| || |__/ 6.0.0-rc.1

Did you forget to “make pycaffe”?
“/home/amitava/caffe” from CAFFE_ROOT does not point to a valid installation of Caffe.
Use the envvar CAFFE_ROOT to indicate a valid installation.
Traceback (most recent call last):
File “/usr/lib/python2.7/runpy.py”, line 162, in _run_module_as_main
main”, fname, loader, pkg_name)
File “/usr/lib/python2.7/runpy.py”, line 72, in _run_code
exec code in run_globals
File “/home/amitava/DIGITS/digits/main.py”, line 70, in
main()
File “/home/amitava/DIGITS/digits/main.py”, line 53, in main
import digits.config
File “digits/config/init.py”, line 7, in
from . import ( # noqa
File “digits/config/caffe.py”, line 226, in
executable, version, flavor = load_from_envvar(‘CAFFE_ROOT’)
File “digits/config/caffe.py”, line 37, in load_from_envvar
import_pycaffe(python_dir)
File “digits/config/caffe.py”, line 126, in import_pycaffe
import caffe
File “/home/amitava/caffe/python/caffe/init.py”, line 1, in
from .pycaffe import Net, SGDSolver, NesterovSolver, AdaGradSolver, RMSPropSolver, AdaDeltaSolver, AdamSolver
File “/home/amitava/caffe/python/caffe/pycaffe.py”, line 15, in
import caffe.io
File “/home/amitava/caffe/python/caffe/io.py”, line 2, in
import skimage.io
ImportError: No module named skimage.io

I’ve updated the ./bashrc file to provide the exact path of Caffe ans python.

Awaiting for help and thanks in advance

Regards
Amitava

Hi Amitava,

do you have noticed, that DIGITS has been released for docker (nvidia-docker)?
The installation is quite easy: https://github.com/NVIDIA/DIGITS/blob/master/docs/DockerInstall.md.

Hope that helps!

For those of us who cannot get it running properly with the Docker container, would you please attempt to answer the question?

ImportError on import skimage.io means skimage.io is missing. Try

sudo pip install scikit-image

It seems that skimage was corrupt. pip install claimed it was up to date. I did a pip uninstall and then pip install and now all works.

Thanks for the efforts to promote DIGITS. Currently, you can run DIGITS docker containers in Ubuntu 18.04 LTS host environment. If you would like to install DIGITS directly into Ubuntu 18.04 LTS, please help create a request in https://nvdigits.ideas.aha.io/ so we can prioritize that feature for community.

Hello, I’m having issues getting Digits up and running (Running Ubuntu 16.04 LTS)
I attempted to Add the Nvidia Developer repository and install the Nvidia driver as described on the digits setup page https://github.com/dusty-nv/jetson-inference/blob/master/docs/digits-setup.md

When I start Installing the Nvidia driver:

“sudo apt-get install -y apt-transport-https curl”
“cat”
“sudo tee /etc/apt/sources.list.d/cuda.list > /dev/null
deb https://developer.download.nvidia.com/compute/cuda/repos/ubuntu1604/x86_64 /”

I get the error :

E: Malformed line 1 in source list /etc/apt/sources.list.d/cuda.list (type)
E: The list of sources could not be read."

I also tried to run the docker pull as described on https://ngc.nvidia.com/catalog/containers/nvidia:digits

When I attempt to install docker:

“sudo apt install docker.io

but get the same error:

E: Malformed line 1 in source list /etc/apt/sources.list.d/cuda.list (type)
E: The list of sources could not be read.

Do I need to remove cuda.list or something else to get docker to install so I can install digits?

thank you

Hi Kraggle,

Can you check if your /etc/apt/sources.list.d/cuda.list contains this line?

deb https://developer.download.nvidia.com/compute/cuda/repos/ubuntu1604/x86_64 /

Note that there is one space between the last ‘/’ and ‘x86_64’.

This command

$ cat <<EOF | sudo tee /etc/apt/sources.list.d/cuda.list > /dev/null
deb https://developer.download.nvidia.com/compute/cuda/repos/ubuntu1604/x86_64 /
EOF
$

at https://github.com/dusty-nv/jetson-inference/blob/master/docs/digits-setup.md basically puts that “deb https://developer.download.nvidia.com/compute/cuda/repos/ubuntu1604/x86_64 /” into cuda.list file. Since the error came from that file, you might just manually add that line.

Thanks, I was able to get it running later after I updated to Ubuntu 18.04 LTS

But now I’m experiencing an issue getting nvidia-docker to work.

How can I get DIGITS to run on Ubuntu 18.04 LTS?

Ref: https://github.com/NVIDIA/nvidia-docker/blob/master/README.md

When I run:

curl -s -L https://nvidia.github.io/nvidia-docker/ubuntu18.04/nvidia-docker.list | \
sudo tee /etc/apt/sources.list.d/nvidia-docker.list

I get:

deb https://nvidia.github.io/libnvidia-container/ubuntu18.04/$(ARCH) /
deb https://nvidia.github.io/nvidia-container-runtime/ubuntu18.04/$(ARCH) /
deb https://nvidia.github.io/nvidia-docker/ubuntu18.04/$(ARCH) /

I run:

sudo apt-get update
sudo apt-get install -y nvidia-docker2

And get:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package nvidia-docker2

I guess your docker.io might be the default installation of Ubuntu 18.04. Can you either upgrade your docker to the latest one or try to follow this document to pin a specific version of nvidia docker (https://github.com/NVIDIA/nvidia-docker/wiki/Frequently-Asked-Questions#how-do-i-install-20-if-im-not-using-the-latest-docker-version)?

I’m in the process of creating a video tutorial on how to get DIGITS installed on a host machine running Ubuntu 18.04 LTS. The process is quite challenging and I faced this exact same error, among others, but I finally got it to work. There are too many steps that I took to get it working, so I can’t pinpoint which one allowed me to get rid of this problem (including reinstalling Ubuntu and Caffe several times over), so hopefully the tutorial will help if you are still trying to tackle this problem.

-Cuda Education
cudaeducation.com

If you are interested, I have outlined a process to natively install NVIDIA DIGITS on Ubuntu 18.04 LTS. I was having trouble using docker, so I went through the torture of figuring out how to natively install it. I suspect it will work for your version of Ubuntu, but I really don’t know.

https://cudaeducation.com/nvidiadigits/

Good luck!

-Cuda Education
cudaeducation.com

Hi Nvidia staffs,

I am also a new to install docker, nvidia-docker (not installed nvidia-docker2) and relevant repositories such as
TAG
nvidia/cuda 9.0-base
nvcr.io/nvidia/caffe 19.11-py3
nvcr.io/nvidia/tensorflow 19.11-tf2-py3
nvcr.io/nvidia/tensorrt 19.11-py3
ubuntu latest
nvcr.io/nvidia/digits 19.10-caffe
hello-world latest
nvcr.io/nvidia/caffe2 18.08-py3

for NVIDIA DIGITS following instruction of 7.7.1 at official website of https://docs.nvidia.com/deeplearning/frameworks/user-guide/index.html#digits_settingup, https://docs.nvidia.com/deeplearning/digits/digits-user-guide/index.html and additionally simple step-by-step procedures at https://github.com/dusty-nv/jetson-inference/blob/master/docs/digits-setup.md; however, I can’t launch a Digits webpage with command of " "nvidia-docker run --name digits -d -p 8888:5000 \ -v /home/username/data:/data:ro -v /home/username/digits-jobs:/workspace/jobs nvcr.io/nvidia/digits:19.10-caffe" (digits:19.10-caffe is latest version I downloaded and installed on docker); But the system showed error message: nvidia-docker: command not found. Or I keyed in other command such as " docker run --gpus all --name digits -d -p 8888:5000 -v /home/username/data:/data -v /home/username/digits-jobs:/workspace/jobs nvcr.io/nvidia/digits:19.10-caffe" Unfortunately, docker showed me error message: “docker: Error response from daemon: Conflict. The container name “/digits” is already in use by container “8906446a515778944312eced571f1aedd699427b80de86a355275f24d04a899e”.You have to remove (or rename) that container to be able to reuse that name.” This message showed me that I have already launched Digits:19.10-caffe but I can’t launch a Digits webpage at localhost:8888 to run Digits.

Could you tell me how to fix it in order for me to launch a Digits webpage successfully please?

Best regards,

Francis