Problem installing Cuda on workstation with QuadroK2200 and TeslaK40 and Ubuntu

Hi,

I have a HP workstation with two cards - QuadroK2200 and TeslaK40.
I have Ubuntu 14.04 running.
I installed cuda7 by downloading from Nvidia download site and then follwing instructions.
But after i reboot, and i try to login, the system gets stuck.
After reading some additional posts, I also created the file for blacklisting nouveau.
If it do Ctrl+Alt+F1, I see the error - could not insert nvidia 346.
I even tried NVidia-xconfig to create a config file for Xserver.
But none of these solved the problem
How do i get the system to work with Cuda

Manually searching for a suitable driver on the NVidia page for K2200 pointed to version 357. Installation failed saying Xserver is running. Killing the Xserver process and installation (using the .run file) also did not work.
Now even removing the drivers using sudo apt-get remove --purge nvidia* does not help.

Perhaps you should read the linux getting started guide.

http://docs.nvidia.com/cuda/cuda-getting-started-guide-for-linux/index.html#abstract