Problem installing driver for Quadro P2200 on CentOS 7

I’m trying to install the driver on a Dell 7920, with 32 GB RAM, Intel Silver 4110 CPU, running the latest CentOS. The kernel is version 3.10.0. There’s just one HP ZR24w monitor connected, so nothing fancy. The installation keeps failing.

There are a few bits of the logfile /var/log/nvidia-installer.log which you might need to look over, so I have attached the log, but the most important bits seems to be these lines, in particular

ERROR: Unable to load the ‘nvidia-drm’ kernel module.

Here’s the end of the logfile, which is
executing: ‘/bin/chcon -t textrel_shlib_t /usr/lib/libnvidia-fbc.so.460.32.03’…
executing: ‘/bin/chcon -t textrel_shlib_t /usr/lib/libnvidia-allocator.so.460.32.03’…
executing: ‘/bin/chcon -t textrel_shlib_t /usr/lib/libnvidia-opticalflow.so.460.32.03’…
executing: ‘/sbin/ldconfig’…
-> done.
-> Driver file installation is complete.
-> Installing DKMS kernel module:
-> done.
ERROR: Unable to load the ‘nvidia-drm’ kernel module.
ERROR: Installation has failed. Please see the file ‘/var/log/nvidia-installer.log’ for details. You may find suggestions on fixing installation problems in the README available on the Linux driver download page at www.nvidia.com.

  • see logfile. I have been using the file NVIDIA-Linux-x86_64-460.32.03.run which is the latest I can download.

nvidia-installer.log (8.6 KB)

I thought I would show this command.
[root@duck /]# lspci | grep -i nvidia
0000:b3:00.0 VGA compatible controller: NVIDIA Corporation GP106GL [Quadro P2200] (rev a1)
0000:b3:00.1 Audio device: NVIDIA Corporation GP106 High Definition Audio Controller (rev a1)

and this

[root@duck /]# lshw -numeric -C display
*-display UNCLAIMED
description: VGA compatible controller
product: GP106GL [Quadro P2200] [10DE:1C31]
vendor: NVIDIA Corporation [10DE]
physical id: 0
bus info: pci@0000:b3:00.0
version: a1
width: 64 bits
clock: 33MHz
capabilities: pm msi pciexpress vga_controller cap_list
configuration: latency=0
resources: memory:fa000000-faffffff memory:e0000000-efffffff memory:f0000000-f1ffffff ioport:f000(size=128) memory:fb000000-fb07ffff
[root@duck /]#

Please make sure you have secure boot disabled in bios.
If that doesn’t help, please run nvidia-bug-report.sh as root and attach the resulting nvidia-bug-report.log.gz file to your post.
Furthermore, you should rather use a driver repo like rpmfusion to install the driver than using the runfile installer.

Thank you. You solved my problem, but not in exactly the expected way.

I disabled secure boot. Then I got into an annoying problem, in that whenever I run NVIDIA-Linux-x86_64-460.32.03.run, it would say it detected the driver, and did I want to continue or not. Whatever I selected the installer exited, which seemed odd, as previously the installer just tried to re-install the driver.

Out of desperation, I thought I would run the massive 2.9 GB file cuda_11.2.0_460.27.04_linux.run to install the full development system. I just selected the driver, and it all seems to work okay now. Running “nvidia-settings” shows the GPU temperature (23 C) and fan speed (44%), so I assume it is all okay. (I had previously tried to install the full development system, but it kept failing on the driver). So it does seem that secure boot was the problem.

I have a Tesla K80 to install, but I thought I would leave installing any more hardware until this problem was resolved. Now I will put the K80 in, and install the full development system.

Can I now enable secure boot again? Security is not a major concern here, as I’m the only one working here.