Problem installing PVF 12.5 on Win 7

Hello.
I’m trying to install PVF 12.5 on Win 7 and experience some licensing problem: my projects do not open. Here is screenshot of error message:

I think there may be some files, record or registry entries about previous installations of PVF (it is not a first time), but i don’t know how to remove them.

Here is also message i’ve got when i run “Generate license” program.

Hi Senya,

The first error is beacuse your license is for PGI Version 9.0 or earlier so needs to be regenerated.

As to why the license generator is failing, I’m not sure. It’s the first time I’ve seen this message and the person who wrote this program is on vacation so I can’t ask.

Do you mind using the online license generator? Log on to your PGI Web User Account (https://www.pgroup.com/account/index.php) and select “Create permanent keys”. After selecting your PIN, select “create license key” for the next available seat, and then press “continue”. You’ll need to know the hostname and FLEXnet hostid. You can get this information by running “lmutil lmhostid” and “lmutil lmhostid -hostname” from a PVF Command Shell.

If you have problems, you can send a note to PGI Customer Support (trs@pgroup.com or license@pgroup.com) and they can better help you through the process.

  • Mat

For some reason after reinstall cycle of PVF 12.5 I found no compilers installed, while Visual Studio and shell start scripts is on their place. Is it possible to fix?

Hi Senya,

That’s odd. I’ve not see that before and the person in change of this is out on vacation this week. Let me ask a few others if they have ideas.

  • Mat

I think PGI installer doesn’t fully removes some registry entries, so new install get confused.
The problem may be because of different versions of PGI was installed before, so there may be mess in registry.
Unfortunatly i can do nothing with this Must Die OS installation, so if you give me advice, how to fix it and clean up everything, PGI installs, i’ll be grateful.

I think PGI installer doesn’t fully removes some registry entries, so new install get confused.
The problem may be because of different versions of PGI was installed before, so there may be mess in registry.

That would be my guess too but I don’t want to tell to start hacking your registry untill I know exactly what to hack. I’ll ask Annemarie to look at this next week when she’s back.

  • Mat

Thank you. I’ll wait for.

Hi Senya,

Would you take a screen shot of your system’s Programs and Features dialog so I can see what the system thinks is installed? Please send it to trs@pgroup.com and ask them to forward your mail to me so we can work through why PVF does not install correctly on your system.

Also, is there a reason you are installing PVF 12.5 rather than the latest version which is 13.8?

Annemarie

I’ll do this later today.
My license finishes with 13.1, but i’m not able to download it from your website.
So i use earlier one.
UPD: i have sent screenshots