Problem of not being able to log in normally in local HDMI after installing jetpack component in production module (Jetpack 4.5)

Hello,

After burning the OS with Jetpack 4.5 on Jetson Nano
I installed the jetpack component.
install command ####################################
https://docs.nvidia.com/jetson/jetpack/install-jetpack/index.html#package-management-tool
sudo apt update

apt depends nvidia-jetpack | awk ‘{print $2}’ | xargs -I {} sudo apt install -y {}
################################################

I can connect via ssh, but the screen doesn’t appear locally.

Can you tell me hot to resolve this problem?

Thank you.

here’s syslog, Xorg.0.log.
syslog (3.3 MB)
Xorg.0.log (24.9 KB)

There is a known issue in jetpack4.5. Please directly try with jetpack4.6.

If you cannot upgrade it to jetpack4.6, then please use sdkmanager to install the sdk instead of debian package.

1 Like

Hello,

Since we developed the camera driver on jetpack 4.5, we need to use jetpack 4.5.

What is the difference between installing with debian package and installing with sdkmanager?

Thank you.

Hi,

I need to correct my point. Please use “rel-32.5.2” and it shall have no such issue. This is just minor update so all the things you run on rel-32.5.1 shall still work.

1 Like

Hello,

https://docs.nvidia.com/jetson/l4t/index.html#page/Tegra%20Linux%20Driver%20Package%20Development%20Guide/updating_jetson_and_host.html

Can I use the following method?
To update to a new point release

1.Enter the command:

$ sudo apt update

apt reads a list of packages from the remote APT repository and identifies new and upgradable packages.

2.Enter the command:

apt list --upgradable

apt displays a list of new and upgradable packages.

3.To install the basic packages for Jetson Linux, enter the command:

sudo apt upgrade

4.Reboot your Jetson device when the upgrade is finished.

Thank you.

yes you can.

1 Like

Hello,

Unable to install jetpack component after upgrading to 5.2. The error message is as follows.

############# jetpack compenent install error ######################
C:\Users\mhbang.ssh>ssh imx566@192.168.1.17
The authenticity of host ‘192.168.1.17 (192.168.1.17)’ can’t be established.
ECDSA key fingerprint is SHA256:RMzHvkY/VbnXBTDwparSLi3CzNQelXeBeEJ1f8ywkBc.
Are you sure you want to continue connecting (yes/no/[fingerprint])? yes
Warning: Permanently added ‘192.168.1.17’ (ECDSA) to the list of known hosts.
imx566@192.168.1.17’s password:
Welcome to Ubuntu 18.04.6 LTS (GNU/Linux 4.9.201-tegra aarch64)

To restore this content, you can run the ‘unminimize’ command.

0 updates can be applied immediately.

Last login: Fri Nov 19 16:23:55 2021 from 192.168.55.100
imx566@imx566-desktop:~$
imx566@imx566-desktop:~$
imx566@imx566-desktop:~$ clear
imx566@imx566-desktop:~$ imx566@imx566-desktop:~$
imx566@imx566-desktop:~$
imx566@imx566-desktop:~$ apt depends nvidia-jetpack | awk ‘{print $2}’ | xargs -I {} sudo apt install -y {}

WARNING: apt does not have a stable CLI interface. Use with caution in scripts.

[sudo] password for imx566:
Reading package lists… Done
Building dependency tree
Reading state information… Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
nvidia-cuda : Depends: cuda-toolkit-10-2 (= 10.2.89-1) but it is not installable
E: Unable to correct problems, you have held broken packages.
Reading package lists… Done
Building dependency tree
Reading state information… Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
nvidia-opencv : Depends: libopencv (= 4.1.1-2-gd5a58aa75) but it is not installable
Depends: libopencv-dev (= 4.1.1-2-gd5a58aa75) but it is not installable
Depends: libopencv-python (= 4.1.1-2-gd5a58aa75) but it is not installable
Depends: libopencv-samples (= 4.1.1-2-gd5a58aa75) but it is not installable
Depends: opencv-licenses (= 4.1.1-2-gd5a58aa75) but it is not installable
E: Unable to correct problems, you have held broken packages.
Reading package lists… Done
Building dependency tree
Reading state information… Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
nvidia-cudnn8 : Depends: libcudnn8 (= 8.0.0.180-1+cuda10.2) but it is not installable
Depends: libcudnn8-dev (= 8.0.0.180-1+cuda10.2) but it is not installable
Depends: libcudnn8-doc (= 8.0.0.180-1+cuda10.2) but it is not installable
E: Unable to correct problems, you have held broken packages.
Reading package lists… Done
Building dependency tree
Reading state information… Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
nvidia-tensorrt : Depends: libnvinfer7 (= 7.1.3-1+cuda10.2) but it is not going to be installed
Depends: libnvinfer-bin (= 7.1.3-1+cuda10.2) but it is not going to be installed
Depends: libnvinfer-dev (= 7.1.3-1+cuda10.2) but it is not going to be installed
Depends: libnvinfer-doc (= 7.1.3-1+cuda10.2) but it is not going to be installed
Depends: libnvinfer-plugin7 (= 7.1.3-1+cuda10.2) but it is not going to be installed
Depends: libnvinfer-plugin-dev (= 7.1.3-1+cuda10.2) but it is not going to be installed
Depends: libnvinfer-samples (= 7.1.3-1+cuda10.2) but it is not going to be installed
Depends: libnvonnxparsers7 (= 7.1.3-1+cuda10.2) but it is not going to be installed
Depends: libnvonnxparsers-dev (= 7.1.3-1+cuda10.2) but it is not going to be installed
Depends: libnvparsers7 (= 7.1.3-1+cuda10.2) but it is not going to be installed
Depends: libnvparsers-dev (= 7.1.3-1+cuda10.2) but it is not going to be installed
Depends: python3-libnvinfer (= 7.1.3-1+cuda10.2) but it is not going to be installed
Depends: python3-libnvinfer-dev (= 7.1.3-1+cuda10.2) but it is not going to be installed
Depends: python-libnvinfer (= 7.1.3-1+cuda10.2) but it is not going to be installed
Depends: python-libnvinfer-dev (= 7.1.3-1+cuda10.2) but it is not going to be installed
Depends: tensorrt (= 7.1.3.0-1+cuda10.2) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
Reading package lists… Done
Building dependency tree
Reading state information… Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
nvidia-visionworks : Depends: libvisionworks (= 1.6.0.501) but it is not installable
Depends: libvisionworks-dev (= 1.6.0.501) but it is not installable
Depends: libvisionworks-samples (= 1.6.0.501) but it is not installable
Depends: libvisionworks-sfm (= 0.90.4.501) but it is not installable
Depends: libvisionworks-sfm-dev (= 0.90.4.501) but it is not installable
Depends: libvisionworks-tracking (= 0.88.2.501) but it is not installable
Depends: libvisionworks-tracking-dev (= 0.88.2.501) but it is not installable
E: Unable to correct problems, you have held broken packages.
Reading package lists… Done
Building dependency tree
Reading state information… Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
nvidia-container : Depends: libnvidia-container0 (= 0.9.0~beta.1) but it is not installable
Depends: libnvidia-container-tools (= 0.9.0~beta.1) but it is not installable
Depends: nvidia-container-csv-cuda (= 10.2.89-1) but it is not installable
Depends: nvidia-container-csv-cudnn (= 8.0.0.180-1+cuda10.2) but it is not installable
Depends: nvidia-container-csv-tensorrt (= 7.1.3.0-1+cuda10.2) but it is not installable
Depends: nvidia-container-csv-visionworks (= 1.6.0.501) but it is not installable
Depends: nvidia-container-runtime (= 3.1.0-1) but it is not installable
Depends: nvidia-container-toolkit (= 1.0.1-1) but it is not installable
Depends: nvidia-docker2 (= 2.2.0-1) but it is not installable
E: Unable to correct problems, you have held broken packages.
Reading package lists… Done
Building dependency tree
Reading state information… Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
nvidia-vpi : Depends: libnvvpi1 (= 1.0.15) but it is not installable
Depends: vpi1-dev (= 1.0.15) but it is not installable
Depends: vpi1-samples (= 1.0.15) but it is not installable
Depends: vpi1-demos (= 1.0.15) but it is not installable
E: Unable to correct problems, you have held broken packages.
Reading package lists… Done
Building dependency tree
Reading state information… Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
nvidia-l4t-jetson-multimedia-api : Depends: cuda-cudart-10-2 but it is not installable
Depends: cuda-cudart-dev-10-2 but it is not installable
Depends: tensorrt but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
Reading package lists… Done
Building dependency tree
Reading state information… Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
nvidia-l4t-jetson-multimedia-api : Depends: cuda-cudart-10-2 but it is not installable
Depends: cuda-cudart-dev-10-2 but it is not installable
Depends: tensorrt but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
imx566@imx566-desktop:~$

Thank you.

Please check /etc/nv_tegra_release to make sure you really upgrade to 32.5.2 first.

1 Like

The following packages have unmet dependencies:
nvidia-l4t-jetson-multimedia-api : Depends: cuda-cudart-10-2 but it is not installable
Depends: cuda-cudart-dev-10-2 but it is not installable
Depends: tensorrt but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
imx566@imx566-desktop:~$ cat /etc/nv_tegra_release

R32 (release), REVISION: 5.2, GCID: 27767740, BOARD: t210ref, EABI: aarch64, DATE: Fri Jul 9 16:01:52 UTC 2021

Hi Hodu,

Please reference below steps to install sdk components on r32.5.2:

$ sudo apt update
$ sudo apt upgrade
$ sudo apt depends nvidia-jetpack | awk '{print $2}' | xargs -I {} sudo apt install -y {}

If you still got errors, please install MMAPI first:

$ sudo apt list -a nvidia-l4t-jetson-multimedia-api
$ sudo apt install nvidia-l4t-jetson-multimedia-api=32.5.2-20210709090156
1 Like

E: Unable to correct problems, you have held broken packages.
imx566@imx566-desktop:~$ sudo apt list -a nvidia-l4t-jetson-multimedia-api
Listing… Done
nvidia-l4t-jetson-multimedia-api/stable 32.5.2-20210709090126 arm64
nvidia-l4t-jetson-multimedia-api/stable 32.5.1-20210519110732 arm64
nvidia-l4t-jetson-multimedia-api/stable 32.5.1-20210505093645 arm64
nvidia-l4t-jetson-multimedia-api/stable 32.5.1-20210219084526 arm64
nvidia-l4t-jetson-multimedia-api/stable 32.5.0-20210115145440 arm64

Which one should I choose?

Hello,

imx566@imx566-desktop:~$ sudo apt install nvidia-l4t-jetson-multimedia-api=32.5.2-20210709090126
Reading package lists… Done
Building dependency tree
Reading state information… Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
nvidia-l4t-jetson-multimedia-api : Depends: cuda-cudart-10-2 but it is not installable
Depends: cuda-cudart-dev-10-2 but it is not installable
Depends: tensorrt but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
imx566@imx566-desktop:~$

Thank you.

Hi Hodu,

Please install 32.5.2 this one:
$ sudo apt install nvidia-l4t-jetson-multimedia-api=32.5.2-20210709090126

Hello, @carolyuu

imx566@imx566-desktop:~$ sudo apt install nvidia-l4t-jetson-multimedia-api=32.5.2-20210709090126
Reading package lists… Done
Building dependency tree
Reading state information… Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
nvidia-l4t-jetson-multimedia-api : Depends: cuda-cudart-10-2 but it is not installable
Depends: cuda-cudart-dev-10-2 but it is not installable
Depends: tensorrt but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Hi Hodu,

Run below commands:

$ sudo apt update
$ sudo apt install nvidia-l4t-cuda 
$ sudo apt install nvidia-l4t-jetson-multimedia-api=32.5.2-20210709090126
1 Like

Hello, @WayneWWW

When I try to install it through the sdk manager because emmc module is being used, it says insufficient disk space.

Thank you.

imx566@imx566-desktop:~$ sudo apt update
Hit:1 https://repo.download.nvidia.com/jetson/common r32.5 InRelease
Hit:2 https://repo.download.nvidia.com/jetson/t210 r32.5 InRelease
Hit:3 Index of /ubuntu-ports bionic InRelease
Hit:4 Index of /ubuntu-ports bionic-updates InRelease
Hit:5 Index of /ubuntu-ports bionic-backports InRelease
Hit:6 Index of /ubuntu-ports bionic-security InRelease
Reading package lists… Done
Building dependency tree
Reading state information… Done
1 package can be upgraded. Run ‘apt list --upgradable’ to see it.
imx566@imx566-desktop:~$ sudo apt install nvidia-l4t-cuda
Reading package lists… Done
Building dependency tree
Reading state information… Done
nvidia-l4t-cuda is already the newest version (32.5.2-20210709090126).
The following packages were automatically installed and are no longer required:
apt-clone archdetect-deb bogl-bterm busybox-static cryptsetup-bin dpkg-repack gir1.2-timezonemap-1.0 gir1.2-xkl-1.0
grub-common kde-window-manager kinit kio kpackagetool5 kwayland-data kwin-common kwin-data kwin-x11
libdebian-installer4 libkdecorations2-5v5 libkdecorations2private5v5 libkf5activities5 libkf5attica5
libkf5completion-data libkf5completion5 libkf5declarative-data libkf5declarative5 libkf5doctools5
libkf5globalaccel-data libkf5globalaccel5 libkf5globalaccelprivate5 libkf5idletime5 libkf5jobwidgets-data
libkf5jobwidgets5 libkf5kcmutils-data libkf5kcmutils5 libkf5kiocore5 libkf5kiontlm5 libkf5kiowidgets5
libkf5newstuff-data libkf5newstuff5 libkf5newstuffcore5 libkf5package-data libkf5package5 libkf5plasma5
libkf5quickaddons5 libkf5solid5 libkf5solid5-data libkf5sonnet5-data libkf5sonnetcore5 libkf5sonnetui5
libkf5textwidgets-data libkf5textwidgets5 libkf5waylandclient5 libkf5waylandserver5 libkf5xmlgui-bin
libkf5xmlgui-data libkf5xmlgui5 libkscreenlocker5 libkwin4-effect-builtins1 libkwineffects11 libkwinglutils11
libkwinxrenderutils11 libqgsttools-p1 libqt5designer5 libqt5help5 libqt5multimedia5 libqt5multimedia5-plugins
libqt5multimediaquick-p5 libqt5multimediawidgets5 libqt5opengl5 libqt5quickwidgets5 libqt5sql5 libqt5test5
libxcb-composite0 libxcb-cursor0 libxcb-damage0 os-prober python3-dbus.mainloop.pyqt5 python3-icu python3-pam
python3-pyqt5 python3-pyqt5.qtsvg python3-pyqt5.qtwebkit python3-sip qml-module-org-kde-kquickcontrolsaddons
qml-module-qtmultimedia qml-module-qtquick2 rdate tasksel tasksel-data
Use ‘sudo apt autoremove’ to remove them.
0 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.
imx566@imx566-desktop:~$ sudo apt install nvidia-l4t-jetson-multimedia-api=32.5.2-20210709090126
Reading package lists… Done
Building dependency tree
Reading state information… Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
nvidia-l4t-jetson-multimedia-api : Depends: cuda-cudart-10-2 but it is not installable
Depends: cuda-cudart-dev-10-2 but it is not installable
Depends: tensorrt but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Hi Hodu,

Looks there are some files broken on your device.
Suggest you can clean flash r32.5.2 and install nvidia-jetpack again.
You can download Driver package and Sample Root Filesystem from here.

1 Like

Hello,

Could you please let me know if there is any other way?

Thank you.