problem on Suse10.2 with 2 GeForce cards

I have 2 NVIDIA cards on my machine,
I have Suse10.2 installed and under /dev directory i have the following files:
crw-rw---- 1 root video 195, 0 2007-04-13 10:41 nvidia0
crw-rw---- 1 root video 195, 1 2007-04-13 10:41 nvidia1
crw-rw---- 1 root video 195, 255 2007-04-13 10:41 nvidiactl

I could install the diriver and the SDK and SDK building process was successful, but when i try to run any of the examples’ executables I get the following error message:

NVIDIA: could not open the device file /dev/nvidia1 (Input/output error).

HW: GeForce 8800 GTS (GPU 0)
OS: Suse 10.2
Driver: NVIDIA-Linux-x86-1[1].0-9751-pkg1

any Idea??

Ahmed

The tips from tachyon_john in this thread worked for me:
http://forums.nvidia.com/index.php?showtopic=28975

Mark

Please make sure that you’ve started X with the nvidia graphics driver.

I’ve just unplugged the 2nd card from the motherboard and then everything worked fine.

I will try at first to deal with one card, then I’ll come back to the issue of having 2 cards running.

Try starting X (e.g. ‘init 5’) and then closing it down later (if necessary) so that the video cards will be properly initialized. You’ll presumably need the device nodes to be read-writeable as well.

John Stone

I have been running a script with the following:

mknod /dev/nvidiactl c 195 255

mknod /dev/nvidia0   c 195 0

mknod /dev/nvidia1   c 195 1

chmod a+rw /dev/nvidia*

modprobe nvidia

Brian