Problem powering Jetson TX2 with 12V battery

Hello,

Sorry if this has already been posted… A quick search has yielded no relevant results.

I am hoping you can assist me with a problem.
I have two Jetson TX2 development boards, and I must hook one up to a turtlebot 2 (autonomous navigation research project).
I’ve found multiple cases of users who power the board with 12V LiPo batteries (some from this forum), but when I power it up with a battery, the CPU power button simply does not work (i.e., the Tegra module does not turn on), even though the red “connection” LED is on.
I am using a Turnigy 3S 11.1V 2200 mAh LiPo Battery from HobbyKing.

I have tried hooking the board to a PSU and slowly raising the voltage to see at which level the Tegra module is able to turn on, which was at 14.5 Volts.
I have also tried a suggestion by user “linuxdev” to put a large capacitor (400 uF) close to the barrel connector. Did not work.
Both of my dev boards display this behavior.

Is there something wrong with my boards? Any comments are appreciated.

Thanks!

Typically the voltage must stay quite stable right at the moment of powering up. 400uF may not be enough. Try a much larger capacitor, or several 400uF. If the wiring to the barrel connector is not a thick gauge, go to heavier wiring. If you don’t have heavier, go to two pairs of what you now use.

If you have the same barrel connector for your tests with both the battery and the PSU, then maybe this indicates barrel connector and/or wire gauge thickness. There are actually two different very close diameter barrel connectors out in the wild which all claim to be the 2.5mm/5.5mm diameter. Some simply have more resistance and at the instant of going on the voltage must be stable (be sure you don’t power directly off of something also powering motors). Take a look at this URL:
https://www.digikey.com/products/en/connectors-interconnects/barrel-power-connectors/435?FV=fff40016%2Cfff80518%2C740002%2C8740005%2C1e88001f%2Cffe001b3&quantity=0&pbfree=1&ColumnSort=0&page=1&stock=1&rohs=1&k=barrel+connector&pageSize=500&pkeyword=barrel+connector
…notice that there is an “actual diameter” listed…sometimes resistance is high (relative to what it needs to be) if you get the inner diameter off a bit. Most connectors are sold as 5.5mm outer/2.5mm inner without even saying that two of the same rating may not be the same thing. This is just to illustrate that the connector itself might be a problem.

Hello linuxdev! Thank you for the answer.

Indeed the barrel connector for the battery and PSU are the same, I just disconnect the contacts from the battery and plug them in my PSU.

I will try to use a larger capacitor at the connector, since it seems easier than scavenging for a new barrel connector. The Tegra module stays on if I lower the voltage to 12 Volts after turning it on at 14.5 Volts.

How large would you recommend? 100 mF sounds good? Connected in parallel, right?

In any case, I’ll try it and let you know how it goes. Thanks again!

Even if not for testing I’d say much larger than 100uF. Now if “mF” is “milli-Farad”…that’ll do nicely :P You might look for the 1000 to 4000uF range. You could even add a tantalum 1uF right at the base on top of all of that. Your concern is a very very short demand spike right as the unit turns on.

Hello linuxdev,

Just to let you know (and for future reference), the capacitor works!
I’ve soldered a 1000 micro-Farad (1 mili-Farad) electrolytic capacitor right in my dev board, in parallel with the barrel connector’s DC jack. I am now able to power on the Tegra module from a 11.1 V battery :)

Thank you so much!