Problem ROS Installation

Hello! I have Jetson TX2 with Jetpack 4.2 and I installed ROS kinetic from But when I want to setup catkin workspace I got this error:

diego@diego-desktop:~/installROSTX2-vL4T28.2.v2$ ./ 
./ line 5: /opt/ros/kinetic/setup.bash: No such file or directory
Creating Catkin Workspace: /home/diego/catkin_ws
./ line 20: catkin_init_workspace: command not found
./ line 22: catkin_make: command not found
export ROS_MASTER_URI=http://localhost:11311
export ROS_IP=

Can you help me?

Hi alberto18_90,

I never tried that, but is thee any instruction for supported L4T version?
Not sure if the script is based on older version to cause this issue as you’re using newer BSP by JetPack 4.2.

Hello. Thanks for your replay. According to JetsonHacks is for L4T Jetpack 3.2
So, what is your advice? How can I install ROS in JETSON TX2?

You can flash the JetPack 3.2 in your TX2 and follow JetsonHacks’ guide, if that helps.

I installed ROS melodic morenia using Jetpack 4.2, following the instructions on ROS website and it worked without any issues.