Problem running some of the sample programs in Ubuntu 14.04 terminal

Hello my name is Harrison. I own a GTX 960. I run Ubuntu 14.04 and have installed linux 64 version 346.47 drivers for GTX 960. I have been trying to install CUDA 7 toolkit for linux following NVIDIA CUDA GETTING STARTED GUIDE FOR LINUX pdf from the official website I found at:

I have reached the part where I have successfully compiled the sample code, but not all of them seem to be working. When executing some such as ./fluidsGL from the terminal I get an error message saying

error while loading shared libraries: libcufft.so.7.0: cannot open shared object file: No such file or directory

However when executing them from the NVIDIA Visual Profiler app I am able to execute fluidsGL. I have noticed it with other ones too, mostly it seems to be the ones categorized as Physical Based Simulation in the official documentation at:

http://docs.nvidia.com/cuda/cuda-samples/index.html#samples-reference

I have created the file nvidia-bug-report.log.gz as requested in the sticky, however I am unsure how to attach it. I can also provide screenshots of the problem if nescisary but I am also unable to find a way to attach it from this site. Do I need to upload images to a third party site such as imageshack and link them here?

you need to

export PATH=/usr/local/cuda-7.0/bin:$PATH
export LD_LIBRARY_PATH=/usr/local/cuda-7.0/lib64:$LD_LIBRARY_PATH

in .bashrc

from

http://docs.nvidia.com/cuda/cuda-getting-started-guide-for-linux/#axzz3X5sJ8gzB

6.1.1

at least that solved the same problem for me