Problem setting up S870

Hi all,

I am trying to set up a Tesla S870 with an HP DL 160 G5 as the host box. I ran the 171-05-pkg2 installer and it ran ok. I ran nvidia-xconfig at the end and that updated my xorg.conf file, but when I tried to restart X, of course it didn’t work, because the DL 160 comes with Matrox onboard video, which is what my monitor is plugged into. I switch the “Driver” in xorg.conf back to mga (from “nvidia”), and the video comes up, but when I run nvidia-settings, it says I’m not using the nvidia driver and to go back and fix X.

How do I load everything I need to use the S870 while still maintaining the ability to use my onboard video out? I’d like to use the onboard video to plug a display into for when we do some demos of what we’re working on.

Tesla: S870 (with both host adapters plugged into the two 16x PCI-E slots in my host)
Host: HP DL 160 G5
OS: CentOS 5.1 (RHEL)
CPU: Intel Xeon (x86_64)



Just to close this out, basically I needed to not run the xconfig, but to create the /dev devices by hand. Once I did that, I was on my way.