Problem wih -mslibs


I am learn to generate a DLL. When I try to include option “-mslibs” using pgf77, it gave me error info: “pgf77… looked for loader at c:/Program Files/Microsoft Visual Studio/VC98/bin/link”

I am using windows XP and my VC is installed in D: drive rather that default, I check env. varibles as wll as sys. variables, nothing wrong.

Can anybody give me a suggestion what should I do? Or maybe you can help me with a correct option in generating the DLL.

Thank you very much.


Hi Ybao,

This is easy to fix. Open the file “ntrc” in your PGI bin directory. Find the line with “variable MSIDR”, and change the default location to the location of your VC installation. Also change MSLINKERDIR a few lines down.

Hope this helps,

Hi, Mat,
It Works! Thank you so much for helping me out!