Problem with Boot, DisplayPort, Ethernet port, and WiFi

I have been facing an issue with my Jetson NX dev kit. The monitor connected to it via DisplayPort is showing nothing. The Ethernet port is inactive. Running nmcli d shows unavailable on eth0. I looked for some other posts on this forum, in the hopes of finding a similar issue, but most of those were fixed with a simple service restart or re-enabling dhcp. They did not work in my case. Ethernet is still unavailable.
As for WiFi, there is a WiFi PCIe M.2 card attached, and it does not show under nmcli d, which is odd.

I did not connect to any suspicious network before having this experience. The device worked for 2 months without flaw, with sparse usage. It was contained well, with no access to dust or ESD.

What did work, however, is the serial IO (through microUSB). I could screen into the dev kit, with no issues, and that is how I could run nmcli (as stated above).
After 1 day of encountering this error, I flashed Jetpack onto a fresh SD card, and tried to boot the Jetson from that. My port issues remained. However, I now have a new problem: The Jetson doesn’t boot. The Power LED is on, and the fan spins at maximum speed. But there is no response from the device through screen.

Lastly, I went back to use the older SD card (the one I had in, when I first encountered this issue), and expected screen to work. But now, that doesn’t work either. Now I am stuck with a board that does not boot, does not output display, and won’t connect to the internet.

The device still has a year of warranty remaining, and I contacted Support through Live Chat. They asked me to post in the official forum, and ask a developer whether or not this was a hardware failure. Could anyone please help me with this? I just need the ethernet and USB to work, and WiFi is not in my list of priorities.

IMO, this is a hardware failure.

But you can still try to dump the log from uart with below tutorial.