Problem with CUDA 8 with 381.09 drivers on Ubuntu 16.04, GTX 1080Ti

I have a problem with some CUDA applications. THey don’t work when I launch as an ordinary user, but do work when I run as root. For example, NVIDIA_CUDA-8.0_Samples/7_CUDALibraries/simpleCUBLAS without root returns:

GPU Device 0: “GeForce GTX 1080 Ti” with compute capability 6.1

simpleCUBLAS test running…
!!! CUBLAS initialization error

But with root works as expected.

Nevermind, I solved the problem.
I had some cache files in ~/.nv directory. After I removed them, it started working!

I even fail to install cuda 8.0 for nvidia 381.09 on my Ubuntu 17.04 …

I’ve got an GTX 980M …

Any suggestions please?


I’m having similar issues with 384.59 (and 384.69). (Ubuntu 16.04.3, CUDA, 1080 Ti)

When running simpleCUBLAS with $HOME/.nv/ on an NFS partition (on which file locking currently fails), I’m getting “CUBLAS initialization error”.

Specifying a local cache path using CUDA_CACHE_PATH=/tmp/ccache fixes the problem.

With the 375.66 driver, simpleCUBLAS works fine with the cache on local as well as NFS volumes.

Some change in the 38x drivers seem to cause issues when the compilation cache is on an NFS volume.

Thanks @lars that solved the problem for me as well.