Problem with CUDA static library on Mac OS X (10.8.x)

Hello all,
I am newbie to CUDA programming. I wanted to integrate CUDA objective C(Xcode ) program with CUDA kernel. I tried many options mentioned in previous threads but the CUDAPlugin link is disabled and most of things don’t work with Xcode 5.
I have also tried to create a static library and linked in my Xcode project (C++/Objective C). There is not compilation error and the host code is excited properly. (print f inside host works fine). But I am not able to execute the kernel code due to which I am getting junk in the destination array in simple copy array elements CUDA kernel.

I have used cuPrintf but no statement inside kernel is printed. But the same program works fine when I run from terminal with mvcc command. Is there any way to link Xcode projects with CUDA. Are then any configuration settings that I need to do? I am running cuds_64.

I also tried Beagle-Xcode but for that also I am getting junk values was out. No compilation errors. Even “HelloWorldQt” prints on statements from host but no statements from kernel is printed.

Please help me to solve this issue. It would be great if its possible to execute CUDA from Xcode. ( it won’t recognize .cu files at all). At least static library linking should work.