Problem with CUDA Video Decoder When using CUDA-based decoder - decoded frames are black

Hello, All!

I have a question. I installed CUDA SDK 3.0 Beta. I find projects in SDK (Release.sln) : cudaDecodeGL and cudaDecodeD3D9. For example, using cudaDecodeGL:

  1. Set variable g_bUseDisplay to true.
  2. Set variable g_eVideoCreateFlags to cudaVideoCreate_Default - all frames were normally decoded and displayed to window.
  3. If I set variable g_eVideoCreateFlags to cudaVideoCreate_PreferCUDA or set command argument = “-decodecuda” - I am getting black screen. I do not know why.
  4. In project cudaDecodeD3D9 got similar result.

Does anybody know why I am get black screen when using “CUDA-based decoder”? (I think that the decoded frames are empty or buffer was not filled)

Help me, please.
Thanks for your reply.

What’s your device model? cuda decocer supports 8800 and above…

I have two devices:

  • NVIDIA Tesla C1060

  • NVIDIA GeForce 8600 GT

hey, i had the similar problem as you had before.

I got some question for you. Once you installed the cuda tools, can you play the default film by using the sample code?

after I installed cuda 2.3 toolkit, I tried to run the first sample code in the NVIDIA SDK Browser which is

“CUDA Video Decoder GL API” and a black screen came out while playing the film named “plush1_720p_10s.m2v”

Therefore i tried to google it and of course tried to find the answer here.

And I tried to do the first step you did “Set variable g_bUseDisplay to true.”

after i set it true, i can play the film smoothly.

Besides, I got the problem for playing H.264 in the mp4 container film. Once i update the lastest driver

for the graphic card (mine is GTX 260), it works.

it’s a bit weird in my mind.

anyway, hope you can try to only use the sample code and modify the first parameter you just mention.

Good luck

Chris

Yes, but before this i have set variable g_bUseDisplay to true. (by default: g_eVideoCreateFlags = cudaVideoCreate_Default)

But, when I had set variable g_eVideoCreateFlags to cudaVideoCreate_PreferCUDA - I am getting black screen(GLUT window). :confused:

Hi. I’m getting the same problem. Setting g_eVideoCreateFlags to cudaVideoCreate_PreferCUDA causes a black screen in cudaDecodeD3D9. Did you ever figure out what’s going on. Thanks.