Problem with driver installation on Linux

Didn’t find an answer here nor on Google search.
Ubuntu 16.04
MATE 1.12.2
NVidia TITAN x (Pascal)

I want to use parallel computing on OpenNMT. It requires fresh NVidia driver downloaded from nvidia.com/Download/index.aspx?
So, I can’t use drivers installed from PPA.

But when I download drivers from " nvidia.com/Download/index.aspx?" and try to run script I get an error:

The distribution-provided pre-install script failed! Are you sure you want to continue?

All the guides from web suggest to install drivers from PPA.

If I ignore the error “pre-install script failed” it gives me an unskippable error:
ERROR: Unable to load the ‘nvidia-drm’ kernel module.

I have already tried different configurations during installation (do or do not register kernel module with DKMS), got rid of an another error “Unable to load the kernel module ‘nvidia.ko’” by editing the modprobe blacklist file.

Now I am out of ideas.
nvidia-installer.log (2.63 KB)
nvidia-bug-report.log.gz (1.07 MB)

Please use the ppa drivers, not the .run installer. Uninstall it first using --uninstall option, then install the ppa driver.

But it is not working for me. My program gives me this error:

.pyenv/versions/main/lib/python3.7/site-packages/torch/cuda/init.py", line 99, in _check_driver
http://www.nvidia.com/Download/index.aspx""")
AssertionError:
Found no NVIDIA driver on your system. Please check that you
have an NVIDIA GPU and installed a driver from
http://www.nvidia.com/Download/index.aspx

Please run nvidia-bug-report.sh as root and attach the resulting .gz file to your post. Hovering the mouse over an existing post of yours will reveal a paperclip icon.
https://devtalk.nvidia.com/default/topic/1043347/announcements/attaching-files-to-forum-topics-posts/

Yes, sure. I had to do this on the first time. Also I attached installation log.

Version mismatch: nvidia.ko(435.21) nvidia-modeset.ko(430.26)

Due to using different install methods you now have a mixed-up driver so nothing works.
Please re-run the .run installer using the --uninstall option to uninstall. Then remove any nvidia driver packages running
sudo apt remove “nvidia*”
in an empty directory. Reboot, reinstall from ppa.
The next problem you’ll hit is that the 16.04 430 driver from ppa is broken:
https://devtalk.nvidia.com/default/topic/1061656/linux/gtx1650-notebook-not-working-on-ubuntu16-04-black-screen-amp-login-loop-/post/5376983/#5376983
I’d rather recommend upgrading to Ubuntu 18.04.

Thanks, you are right. Everything works now

Good afternoon all,
Today I downloaded the latest Linux64 bit driver for the Quadro K2200 from the following link - https://us.download.nvidia.com/XFree86/Linux-x86_64/460.80/NVIDIA-Linux-x86_64-460.80.run.
On my CentOS 7 box the driver that was installed was 430.50 I did the following:
./NVIDIA-Linux-x86_64-430.50.run --uninstall. This reported that it uninstalled successfully. I then ran the installer for the latest driver ./NVIDIALinux-x86_64-460.80.run this installed successfully. When I go to run the installer again it says that I have version 460.80 installed see screenshot labeled (AlreadyInstalled.png) So at this point it appears that I have the latest and greatest driver installed, however from the command line when I do a glxinfo command you will see in the screenshot (VersionString.png) that the version is reporting as 452.57. This version is strange to me because I have never had this version on my system.


So the question is, is the version information in the driver incorrect or is the driver version I installed incorrect?

It won’t allow me to post the version string attachment. This is reported as the following: OpenGL version string: 1.4 (4.6.0 NVIDIA 452.57) from glxinfo