Problem with GTX 1060 any latest driver after a restart

CentOS 7.6. This hardware works with the nouveau driver. But I need a special hook that the proprietary driver has.

I’ve made some changes and gotten it to this, but X just doesn’t start. The whole log:

# cat /var/log/Xorg.0.log
[  8414.140] (--) Log file renamed from "/var/log/Xorg.pid-9667.log" to "/var/log/Xorg.0.log"
[  8414.140] 
X.Org X Server 1.19.6
Release Date: 2017-12-20
[  8414.140] X Protocol Version 11, Revision 0
[  8414.140] Build Operating System:  4.18.10-200.fc28.x86_64 
[  8414.140] Current Operating System: Linux cygnus.darkmtter.org 4.19.7-200.fc28.x86_64 #1 SMP Wed Dec 5 22:47:13 UTC 2018 x86_64
[  8414.140] Kernel command line: BOOT_IMAGE=/vmlinuz-4.19.7-200.fc28.x86_64 root=/dev/mapper/fedora_cygnus-root ro resume=/dev/mapper/fedora_cygnus-swap rd.lvm.lv=fedora_cygnus/root rd.lvm.lv=fedora_cygnus/swap rd.driver.blacklist=nouveau nouveau.modeset=0
[  8414.140] Build Date: 01 November 2018  04:04:19PM
[  8414.140] Build ID: xorg-x11-server 1.19.6-10.fc28 
[  8414.140] Current version of pixman: 0.34.0
[  8414.140]    Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.
[  8414.140] Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[  8414.140] (==) Log file: "/var/log/Xorg.0.log", Time: Tue Dec 11 14:06:11 2018
[  8414.141] (==) Using config file: "/etc/X11/xorg.conf"
[  8414.141] (==) Using config directory: "/etc/X11/xorg.conf.d"
[  8414.141] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[  8414.141] (==) ServerLayout "Layout0"
[  8414.141] (**) |-->Screen "Screen0" (0)
[  8414.141] (**) |   |-->Monitor "Monitor0"
[  8414.141] (**) |   |-->Device "Device0"
[  8414.141] (**) |-->Input Device "Keyboard0"
[  8414.141] (**) |-->Input Device "Mouse0"
[  8414.141] (==) Automatically adding devices
[  8414.141] (==) Automatically enabling devices
[  8414.141] (==) Automatically adding GPU devices
[  8414.141] (==) Automatically binding GPU devices
[  8414.141] (==) Max clients allowed: 256, resource mask: 0x1fffff
[  8414.141] (==) FontPath set to:
        catalogue:/etc/X11/fontpath.d,
        built-ins
[  8414.141] (==) ModulePath set to "/usr/lib64/xorg/modules"
[  8414.141] (WW) Hotplugging is on, devices using drivers 'kbd', 'mouse' or 'vmmouse' will be disabled.
[  8414.141] (WW) Disabling Keyboard0
[  8414.141] (WW) Disabling Mouse0
[  8414.141] (II) Loader magic: 0x825e00
[  8414.141] (II) Module ABI versions:
[  8414.141]    X.Org ANSI C Emulation: 0.4
[  8414.141]    X.Org Video Driver: 23.0
[  8414.141]    X.Org XInput driver : 24.1
[  8414.141]    X.Org Server Extension : 10.0
[  8414.142] (++) using VT number 1

[  8414.142] (II) systemd-logind: logind integration requires -keeptty and -keeptty was not provided, disabling logind integration
[  8414.142] (II) xfree86: Adding drm device (/dev/dri/card0)
[  8414.151] (--) PCI:*(0:9:0:0) 10de:1c02:1043:85b9 rev 161, Mem @ 0x90000000/16777216, 0x800000000/268435456, 0x810000000/33554432, I/O @ 0x00007000/128, BIOS @ 0x????????/65536
[  8414.151] (II) LoadModule: "glx"
[  8414.151] (II) Loading /usr/lib64/xorg/modules/extensions/libglx.so
[  8414.153] (II) Module glx: vendor="X.Org Foundation"
[  8414.153]    compiled for 1.19.6, module version = 1.0.0
[  8414.153]    ABI class: X.Org Server Extension, version 10.0
[  8414.153] (II) LoadModule: "nvidia"
[  8414.153] (II) Loading /usr/lib64/xorg/modules/drivers/nvidia_drv.so
[  8414.153] (II) Module nvidia: vendor="NVIDIA Corporation"
[  8414.153]    compiled for 4.0.2, module version = 1.0.0
[  8414.153]    Module class: X.Org Video Driver
[  8414.153] (II) NVIDIA dlloader X Driver  410.78  Sat Nov 10 22:15:52 CST 2018
[  8414.153] (II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
[  8414.153] (II) Loading sub module "fb"
[  8414.153] (II) LoadModule: "fb"
[  8414.153] (II) Loading /usr/lib64/xorg/modules/libfb.so
[  8414.153] (II) Module fb: vendor="X.Org Foundation"
[  8414.153]    compiled for 1.19.6, module version = 1.0.0
[  8414.153]    ABI class: X.Org ANSI C Emulation, version 0.4
[  8414.153] (II) Loading sub module "wfb"
[  8414.153] (II) LoadModule: "wfb"
[  8414.153] (II) Loading /usr/lib64/xorg/modules/libwfb.so
[  8414.153] (II) Module wfb: vendor="X.Org Foundation"
[  8414.153]    compiled for 1.19.6, module version = 1.0.0
[  8414.153]    ABI class: X.Org ANSI C Emulation, version 0.4
[  8414.154] (II) Loading sub module "ramdac"
[  8414.154] (II) LoadModule: "ramdac"
[  8414.154] (II) Module "ramdac" already built-in
[  8414.154] (**) NVIDIA(0): Depth 24, (--) framebuffer bpp 32
[  8414.154] (==) NVIDIA(0): RGB weight 888
[  8414.154] (==) NVIDIA(0): Default visual is TrueColor
[  8414.154] (==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
[  8414.154] (**) NVIDIA(0): Enabling 2D acceleration
[  8414.154] (II) Loading sub module "glxserver_nvidia"
[  8414.154] (II) LoadModule: "glxserver_nvidia"
[  8414.154] (II) Loading /usr/lib64/xorg/modules/extensions/libglxserver_nvidia.so
[  8414.158] (II) Module glxserver_nvidia: vendor="NVIDIA Corporation"
[  8414.158]    compiled for 4.0.2, module version = 1.0.0
[  8414.158]    Module class: X.Org Server Extension
[  8414.158] (II) NVIDIA GLX Module  410.78  Sat Nov 10 22:12:55 CST 2018

If it doesn’t start it should give some kind of error.

nvidia-bug-report.log.gz (2.12 MB)

Please run nvidia-bug-report.sh as root and attach the resulting .gz file to your post. Hovering the mouse over an existing post of yours will reveal a paperclip icon.
https://devtalk.nvidia.com/default/topic/1043347/announcements/attaching-files-to-forum-topics-posts/

Hi,

Thanks, it’s attached to the OP.
nvidia-bug-report.log.gz (3.15 MB)

The log is flooded with

Dec 10 12:11:27 cygnus kernel: NVRM: rm_init_adapter failed for device bearing minor number 0
Dec 10 12:11:27 cygnus kernel: NVRM: RmInitAdapter failed! (0x23:0x56:475)

Is this in a VM or on bare metal? In the latter case, please reseat the card, check if it works in another slot, check with another system to rule out a hw issue.
The fact that nouveau works doesn’t mean much since nouveau can’t reclock.

Ok I’ve reseated the card and now the log is practically empty. (my post#3) But still no X.

Yes this is passed through to a KVM virtual machine.

In case of KVM, you have to hide the hypervisor. Reseating etc. was in case of bare metal.

Nice, thanks.

For those who don’t know, nVidia doesn’t like you to pass through the video card to a virtual machine and use their proprietary driver. Most hypervisors don’t allow you to hide that it’s in a VM, but KVM does.

Shut down the VM with the passed-through video card, and virt-manager. Then

EDITOR=nano virsh edit {VM name}

… and inside add:


Save and exit. Restart virt-manager and start the VM with the video card.

Hm, I do now have X.

As it’s CentOS 7.6 I get the sddm login screen. But the text is way too small. The nViidia must not be picking up that the projector is 1920x1080 and is setting res much higher.

I ran the nvidia-xconfig when installing the driver and that doesn’t seem to be doing it, so I’ve set it aside. No change and it’s still loading the nvidia driver.

I logged in and got only the cursor on a black screen. Found that was because somehow my ~/.Xauthority for set to root 6. Fixed that and now get logged in with all its glory.

But the text is still way too small. Can’t even read it to set it higher, and I doubt the problem is a setting anyway. The screen is being properly sized at 1920x1080.

Ok the solution to text too small in KDE is $ systemsettings|Fonts|ForceFontsDPI=96.

Or if you’re still using their xorg.conf, add this under [Screens]
Option “DPI” “90x90”
Option “UseEdidDpi” “False”

Now thanks to generix, I’m rockin’ it like they do downtown. I have TV again!