problem with hibrid graphics on laptop (X11 error and restart, text console blinks)

Hello,

I’m trying to configure a laptop, toshiba satellite pro with a GM108M [GeForce 930M] (rev a2).

The OS is opensuse leap 15, with default kernel 4.12.14 and also has been tested with 4.17.12
The nvidia drivers tested have been 390.77 and also with 396.51, which is the one currently installed.

I have tried bumblebee but then resume doesn’t work.

I’m trying to configure it from the beginning, but nvidia is not a VGA controller :

lspci |egrep -i “3d|vga”

00:02.0 VGA compatible controller: Intel Corporation Skylake GT2 [HD Graphics 520] (rev 07)
02:00.0 3D controller: NVIDIA Corporation GM108M [GeForce 930M] (rev a2)

Trying to startx with a xorg.conf file, hand-made, or from nvidia-xconfig, graphics don’t start and the text console “blinks” as X restarts.

Adding a sleep 5 to:
/usr/share/sddm/scripts/Xstop

Makes the system usable when restarts begin.
Deleting xorg.conf makes X start again, but without 3d acceleration.

I have attached the nvidia bug report when the X is restarting.

Any ideas ?

Thanks.

nvidia-bug-report.log.gz (88.1 KB)

Ok, now the suspend bug hit, you’ll have to reboot.
The error that is displayed

[ 2840.342638] NVRM: RmInitAdapter failed! (0x26:0xffff:1123)
[ 2840.342670] NVRM: rm_init_adapter failed for device bearing minor number 0

Did you add the xrandr commands to your display manager’s config, so your desktop is running?
e.g. in case you’re using sddm
add to the file
/usr/share/sddm/scripts/Xsetup

xrandr --setprovideroutputsource modesetting NVIDIA-0
xrandr --auto

To check what kind of suspend bug you have, please run
sudo acpidump >acpidump.txt
and attach that to your post.

Thanks for another fast reply.

Yes, I have put those two xrandr lines in several places, specifically it is in the Xsetup file.

I have attached the acpidump, but right now the laptop suspends/resumes fine, as the nvidia is disabled, even as the modules are loaded, and there is no gl accel.

For example, if I run blender it says:

/home/abuild/rpmbuild/BUILD/blender-2.79b/intern/ghost/intern/GHOST_WindowX11.cpp:198: X11 glXQueryVersion() failed, verify working openGL system!
initial window could not find the GLX extension
Writing: /tmp/blender.crash.txt

Thanks
acpidump.txt (1.04 MB)

Ok, the bad news is, I think you’re really suffering from exactly the same bug as the people from the previous thread. The good news is, I possibly found a workaround in your case.
Please add the kernel parameters
acpi_osi=! acpi_osi=“Windows 2012”
to your grub config, reboot.
https://doc.opensuse.org/documentation/leap/reference/html/book.opensuse.reference/cha.grub2.html#sec.grub2.file_structure
Then check if you can properly suspend/resume when using the nvidia gpu. Run dmesg >dmsg.txt and attach that.
To get X working while on intel, create/attach a new nvidia-bug-report.log while on intel.

That has been incredible. After several days everything works fine, the suspend/resume, the brightness keys…

I tried before the acpi_osi= in grub, but not that exact combination.

I have seen strange/complicated configurations before, but this one is absurd from my point of view.
You cannot discover the solution unless someone tell you, there are simply too many factors to configure.

At the end I have done a:

zypper in bumbleee

To reinstall bumblebee, do a systemctl enable bumblebeed.service
to enable it (systemctl start bumblebeed.service before to try it).

After that I have found a “typical” problem, after the resume the gpu doesn’t restart, gives an error:

I have solved it by doing :

echo 1 | tee /sys/bus/pci/rescan

I will put that in some script, so it is automatically executed when resuming.

Thanks!!!