Problem with Isaac Gym

Hi,
I tried to setup install isaac Gym. After installation following the instructions and trying to start joint_monkeys or any other example I got error:


I was unable to find a solution to it. This are nividia-smi results:

Hi @piotrklima1996 - Are you following instructions mentioned in this page?
https://docs.omniverse.nvidia.com/isaacsim/latest/isaac_gym_tutorials/tutorial_gym_isaac_gym.html

Yea, I have followed t he instruction and I get the same error trying to install isaac sim to use isaac orbit for RL.

X Error of failed request: BadRequest (invalid request code or no such operation)
Major opcode of failed request: 143 (GLX)
Minor opcode of failed request: 29 (X_GLXGetDrawableAttributes)
Serial number of failed request: 16
Current serial number in output stream: 16
2024-03-05 10:33:55 [4,553ms] [Warning] [omni.core.ITypeFactory] Module /media/data/installs/isaac/lib/isaac_sim-2023.1.1/kit/exts/omni.activity.core/bin/libomni.activity.core.plugin.so remained loaded after unload request.

I was able to install isaac sim with nucleus and cache but I am unable to start it. The Isaac Sim App Selector doesnt pop up.

I am following the intructions from the Workstation Installation — Omniverse IsaacSim latest documentation

Hi. Do you have a display monitor connected to the RTX 8000?

Yes, I have display monitor connected to the workstation.

Following the troubleshooting with linux guide I checked to be sure:
echo $DISPLAY
:50.0

Can you share the output or xrandr?