Problem with loading module via modprobe

Hello, im trying to use tty0tty in order to make virtual com-ports.

I follow the instructions give here

On the step 5

Everytime i get the error

I have tried insmod with the same error.

I cant see any implementations of tty0tty in lsmod, or virtual ports in /dev/tnt*
What should I do?

Thanks in advance, nikitap.

Hello, nikitap:
That’s a general Linux kernel driver issue.
I checked the driver code. With major (240) and minor (1/2/3), that dev node is occupied by ttyTHS1/2/3.
You can add tty0tty_tty_driver->minor_start = 16 before calling tty_register_driver, and that can work.


Hi jachen,
I did this modification you suggest, after that I change the TTY0TTY_MINORS to 16, but the system refuses to insert module:
modprobe: ERROR: could not insert ‘tty0tty’: Device or resource busy

can you help-me?


Hello, alfredosalvarani:
Sorry that I’ve not worked on this for long time.
But per my understanding, you can check the kernel code.
And find out the major/minor number for the device you want to register, and find out why it’s conflicted with current system.

Hope that can help.