Problem with mass of a RigidBody

Hi Everyone,

I’m having a problem in my scene where if i set the mass to any large number the simulation becomes very unstable. When i say a large value i mean anything above 50 or so, not really that large. If i set a mass of 1.0 the simulation runs perfect.

I am using the PxRigidBodyExt::setMassAndUpdateInertia method. If you check the pvd files you will see what i mean.

Is this a timming issue? I have tried everything else i could think of to try and fix the issue. (441 KB)

One thing i noticed is that the mass space inertia tensor is 1 1 1 , when i load up the exact same scene but using physx 2.8 (engine has a plugin system with physx 2.8 and 3.2) the mass space inertia tensor has a completly different value and when i manually enter that value in to physx 3.2.5 from the first post the problem dissapears.

With physx 3.2 i though PxRigidBodyExt::setMassAndUpdateInertia would calculate this for you?


Don’t mind me i have had a shocker, i was calling PxRigidBodyExt::setMassAndUpdateInertia before i had created the shape with the actor, all solved and working great now :-)